Disable monospace standard ligatures

Hi, I’m working on a monospaced font and I’m wondering what is the best practice for standard unicode-based ligatures like fi (uni FB01) and fl (uni FB02).

I don’t want them on or automatically replacing characters for the user, and also not have to direct them to turn off ligature settings (i.e., if they type /f /i, then I want it to appear as those glyphs and not substitute with the ligature).

Should I keep these glyphs as part of the glyph set upon export to avoid any missing standard characters for certain programs. If so, how do I properly disable them so they don’t show up?

Or is there a better way?

Thank you.

The glyphs by itself are not showing up (only if the user puts in the specific Unicodes.
So you just make sure you don’t have a ligature feature.

What you can do is to add a decomposition rule in the ccmp feature:

sub fi by f i;

That will not work everywhere but isn’t hurting either.

Thanks for the info and advice Georg. Will try this out. Appreciate it.

Provided the renderer in use supports substitution features and ccmp:

  1. Make the ligatures pure composites of their individual letters (so there is no visual difference between the individually typed, unligated glyphs, and the ligature.
  2. Disable the Liga feature.
  3. that leaves only two ways to insert the ligature now: by its Unicode or a glyph insertion mechanism like a glyph palette. So, in ccmp, add decompositions like sub fi by f i; etc.

(Sorry just saw that Georg was quicker. I had written the answer but it didn’t go through the first time.)

If it’s for coding, I personally wouldn’t recommend it because there might be situations where you do want to deal with these characters (I would just disable the liga feature).

Alternative approach is to just embrace it, having fun with the idea of these silly things being single glyphs.

Thanks much for the feedback @mekkablue and @Tosche. That /ffb lig is intriguing :slight_smile:

It’s more for stylistic reasons, rather than coding intentions or the like.

Yes, seems that including the ligature glyphs (I do have them as same width as the other glyphs, but condensed the drawing) and disabling the feature in Glyphs app is working. I can still insert them if desired via the Glyphs panel in AI, for example.