Double Quotes not typing out in Text Edit/Office

Hi. This is the first typeface I’ve worked on in Glyphs, the program is awesome and so far I’ve been able to find tutorials and answers to all of my problems except one.

I’ve exported the font and everything works well in Adobe programs, but I’m having issues with double quotes and apostrophes displaying in Text Edit or Word. It doesn’t display when I type the characters out with the typeface selected, but it displays as a default typeface.

The weird thing is if I type something out with the quotes, then highlight it and select the typeface, everything displays correctly.

I have a screenshot but can’t post because I’m new. I’ve tried clearing out cache, creating prime and double prime glyphs, nothing seems to work. Thanks.

This is probably a font cache problem. Read this please:

Tried it, still having issues.

can you send us the .glyphs file?

Absolutely. Where should I send it?

support (at) (this website without www)

How are you typing the quotes? Are you just typing straight quotes, then let the software replace them with curly quotes? For this to work, there need to be straight quotes in your font. To avoid trouble like this, it is a pretty good idea to have at least the MacRoman and Windows 1252 lists in your font.

Just typing out on a Mac keyboard. Like I said, if I have the typeface selected everything types out fine until I get to the double quotes, then it displays a default font, but then if I was just to select that same bit of type and choose that typeface, it recognizes the double quotes and displays them correctly. This only happens in Text Edit/Word, in the Adobe programs it types out just fine.

@brink Have you tried the suggestions in my previous post?

Amazing! Thank you. I figured that it had something to do with straight quotes or primes, just didn’t know where to look. Works like a charm. Thank you.