Empty Adobe glyphs Panel

Im experiencing an odd issue in Adobe apps. In illustrator some feature categories (ss04, ss05, ss06) are empty in the glyphs panel and in Indesign this categories are not shown in the dropdown menu. If I activate the feature via the app interface everything works. But why the glyphs panel is empty for this features? ss01, ss02, ss03 are displayed correctly.

Thanks in advance!

You are testing through the Adobe Fonts folder?


Delete the .lst files in the Adobe Fonts folder and restart the Mac. Make sure there is no conflict with system-installed fonts.

No .lst file in the folder, I have hidden files visible.

Try this: https://forums.adobe.com/thread/326543

Didn’t work. I’ve tried in two computers different OS, different Adobe Version.
I think is related with my futures but this is my code in ss04 for instance.

lookup FINAL2 {							
   ignore sub @fina2OFF' @AllLetters;							
   sub @fina2OFF' by @fina2ON;

It might be that the stylistic sets are supposed to have simple one to many substitutions. Add one lookup like this

lookup Simple {							
   sub a by a.ss04;
} Simple ;

Oh, and make sure you update your aalt feature.

This worked, Thanks!
I can’t understand why I can’t use clases. :rage:

You can use classes. But only simple substitutions without context.