Error message when trying to fix Overpass font


I am using the open source font family Overpass. There is a very annoying line height bug in Firefox and (most important to me) Sketch.

Referring to this solution I tried to modify the .glyphs file and export a new font with disabled “Use Typo Metrics”:

Sadly I ran into an error:

There was a problem converting the PostScript source font. (Thin)

As there is no official update for the font for three years I would love to get rid of the bug. by myself or with the help of a pro.

Can somebody help?

Thank you very much!

You should first report the issue to the author on github so they have a chance to fix it. There is a tab called “Issues” for that very reason.

Here is a tutorial that may help:

Which exact version of the app are you using?

The second link I provided is a pull request for this issue, but it is open since Aug 20, 2018 now. The font itself was not updates for three years so I might figure out something by myself.

Thanks for the link. Seems like there is no generateFont.command generated. Only and GlyphOrderAndAliasDB are generated.

I am using the latest version Version 2.6.1 (1230).

I just noticed that at least one of the designers reads and posts in this forum. Hopefully he will see this and take action.

I just tried exporting the latest cutting edge version (2.6.2-1242) and it exports it just fine.

That sounds great! I will try to export it on another Mac tomorrow.

Would it be possible for you to provide the .otf files to me?

Hello guys, did you find how to fix it?

I tried on glyphs but I don’t know how to disable the “use typo metrics” as explained in github.
If you succeeded would you share it, or would be glad to know how you did it :slight_smile:



You can add a “Use Typo Metrics” custom parameter in the Font or Instance/Exports settings.

1 Like

Seems that the line height issue was corrected in Overpass release 3.0.4

1 Like

Hello guys, Thank you so much. Resolved!

Someone shared an update available here

I tried, and it is now fixed in Firefox. Youpi!