Error: "Something went wrong when Removing Overlap"

I just upgraded to 3.0.2 on 10.15.7. I opened an old font file and wanted to re-export it and am now getting an error message saying "Something went wrong when Removing Overlap in glyph: W.ss03.

I followed other forum posts the topic, and also tried deleting the glyph, recompiling features and creating a new one. And I always get the same error. Note, there is another glyph in the font with the ornament on the left, and there is no issue with that Glyph.

Note - I did try to Export both as File Format Version 2 and 3

I did Add PUA values to all the Stylistic Sets, but no other glyph is giving me this error.


The very short and very flat curve segments can confuse the Remove Overlap algorithm. Can you please send me the .glyphs file to support (at) (this website without www). I will have a look.

We are working on it. Can you send that glyph for testing.

But for now, disable the Remove overlap in the export dialog for now.

I have the same bug with version 3.0.2 (3043).

I have improved the algorithm over the weekend. Will upload a new version, soon.

On my side, resolved with 3.0.2 (3044) :slight_smile:

Hey. On version 3.0.2 (3053) I still have this issue, which (so far) primarily seems to be with getting hung up on diacritical glyphs — specifically E-related ones …
Oddly, in the official last release of version 3.0.1, the issue was with different diacritics. For example, the issue was first with the Ecircumflex (decomposing it helped get passed that one) and then Edieresis; now it’s hung up on Eacute, which it previously got passed.

Can you please send me the .glyphs file to support (at) (this website without www). I will have a look.

Will do. Thanks … to confirm “this website” means also without the “forum.”, correct?

yes, just the domain name

Got it. Thanks! Just sent.

  1. In Font View (Cmd-Op-1), select all glyphs (Cmd-A).
  2. Choose Paths > Correct Path Direction (Cmd-Shift-R)
  3. Then export again.

Thanks. Yes, that’s resolved it …