Error when launching G3 + Show Distance and Angle plugin

Whenever I try to use @Mark’s lovely Show Distance and Angle plugin, Glyphs 3 won’t load it and gives me this at launch:

I’ve done what the dialog asks, running pip3 install pyobjc sucessfully, several times from the Terminal. I’ve already got Xcode installed as well. I have both the Glyphs Python 3.8.2 and the 3.9.5 installed and it doesn’t matter which one I select in Glyphs, I get the same error at launch.

I would just ignore it, but the plugin isn’t loading. I’ve tried uninstalling, quitting, reinstalling, quitting, and relaunching, but no dice. I’ve tried installing straight from GitHub, but no dice.

I’m on Glyphs 3.0.2 (3058), not the cutting-edge version.

Any tips? Thanks.

Can you remove and reinstall the python module in plugin manager and make sure to select it in preferences?

I had the same thought, but it’s not there in the first place:

What version of Glyphs do you have? And what version of MacOS?

This error is happening on:

Glyphs 3.0.2 (3058)
macOS Big Sur 11.3.1
M1 MacBook Air

Please update to the latest cutting edge version.

1 Like

Yes, the Python module is available again for newer builds, e.g., the latest beta. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.

1 Like

Those things mentioned by Georg and mekkablue should help you out, once you got it it should appear as in my GLyphs 3, with almost the same computer setup:

Screenshot 2021-05-05 at 09.45.28


1 Like

Thanks @GeorgSeifert @mekkablue @Mark for all of your help. The cutting-edge version indeed fixed the issue after a quick reinstall of the plugins.

I had been avoiding the cutting-edge version to play it safe, but it turns out I should have been using it anyway. :slightly_smiling_face: Thanks again.