"Error with glyph: space"


#1

Weirdest of errors. There is no issue with the name. When I delete the space, the error is repeated with the ‘exclam’.


#2

What version of Glyphs do you have?
Can you send me the .glyphs file?


#3

running Version 2.4.2 (1057) - what’s a good email?


#4

Can you run the mekkablue script Glyph Names > Check Glyph Names? And report back what it writes in Window > Macro Panel?


#5

Nada. Didn’t open the macro panel. Will check if the script needs updating.


#6

Updated script also doesn’t open Macro panel.


#7

It does not open he macro panel by itself (will add that later), just open it yourself, please: Window > Macro Panel


#8

Hey there!
Having exactly the same problem. Just ran Check Glyph Names script in Macro Panel and didn’t get any answer. I can export the whole set of glyphs without troubles, but as soon as I try exporting just a few selected glyphs (through Instances – Keep Glyphs), I get this weird message. Any developments in the last couple of days that you might be able to share? Thanks a lot!


#9

Can you send me the .glyphs file (send a dropbox link in a DW in the forum).


#10

Between first line Start and last line End, I have a list of all of my non exporting underscored-prefixed glyphs listed as “potentially problematic first character”


#11

I forgot that I also have a KeepGlyphs parameter set as well


#12

Hey there!

I just solved my problem. Inp, maybe this might be helpful for you too?
The key is HOW to select the glyphs that you’d like to export:
First I selected only the glyphs I want to keep in the list of all glyphs. Then, I right clicked, so window in screenshot no.1 appeared. (Everything in German – My apologies). At the very bottom, select “Copy Glyph Names”, then choose the 2nd option from the top (“Zeilenweise” = “in line” or something). That should list you each selected glyph in a separate line, once you paste them in your Instances – Parameter – Keep Glyphs Window. Then export. Everything should be there and no weird error message.

Hope that helps!

![33|450x500]


#13

This is how the Parameters list should look like, when pasted correctly:


#14

Nice one! That makes total sense :o) Thanks


#15

Cool. Glad I could help.


#16

Thanks, Georg. I think I solved the problem. :slight_smile:


#17

One per line, in English.


#18

Thank you!


#19

I made glyphs automatically break it down into lines.