"exclude:" parameter of the prefilter seems not to work properly

The “exclude:” parameter of the prefilter seems not to work properly. The _part.dot component should not be outlined and should stay filled, but it doesn’t work. It worked in Glyphs 2, with the same file.

Is that in the preview only or also in the exported font?

It’s both in the preview and in the exported font, and both with filter and prefilter

I think I fixed an issue with the exclude/include code just after uploading the latest version. This should fix your problem.

It says I’m up to date, including the cutting edge versions, but it still doesn’t work

I said after I uploaded the latest version.

My bad, thanks !

Any news on this? I need to use the “exclude”.

Thanks, it’s indeed working again ! There is another problem though, even though the export works well now, the preview isn’t displaying the typeface correctly, it’s previewing the typeface as if the “exclude” parameter was an “include” parameter. If I replace the “exclude” parameter by “include”, it’s previewing the way it should, but then it’s the export that is messed up.

As far as I can see, it works as expected. Can you send me that file?

The problem is in the preview, it shows the dot components outlined and the path not outlined, the exact opposite as the export result. Here is the file !

test.glyphs (1.5 KB)

You are right. The preview got it wrong. Fixed it.