Excluding glyphs on export?


#1

I’ve been trying to search for answers to a question I have, but I think I’m searching for the wrong terms. What I’m hoping to do is export only certain glyphs, so I end up with a bare-bones font with all caps (that also cover lowercase), numbers, and very basic punctuation. Is there a way to exclude a range of glyphs from output? Can it be done with a custom parameter in an instance?


#2

Right click on the glyphs in Font View, or right-click in edit view, and you can activate or deactivate export. Or use the custom parameter “Remove Glyphs”


#3

Thanks! This worked as expected, except for the lowercase. My goal may be unrealistic. I want uppercase to be displayed regardless of whether uppercase or lowercase characters are typed, but I prefer not to actually delete the lowercase glyphs. It seems like it may be easier to duplicate the file and destructively customize it to achieve what I want.


#4

Put components of the uppercase characters into the matching lowercase characters.


#5

I think I am misunderstanding something. If I put uppercase components into the lowercase slots, where would my lowercase characters go? I don’t want to lose them. I just want to turn them off temporarily to create a simplified all-caps font. It seems like maybe what I want to do can’t be done with a single file. I may just duplicate the file and delete the lowercase. If I have read correctly, the uppercase will take over the lowercase automatically.


#6

Then you need an instance with a combination of the Remove Glyphs and Reencode Glyphs parameters.


#7

Thanks. This gives me something to study.


#8

I got this working the way I wanted on my Mac in Illustrator. In case it helps someone trying to do the same thing, I am noting what I did.

  1. Created an instance called “Caps”
  2. Created a “Remove Features” custom parameter for that instance:
    ccmp
    liga
    calt
  3. Created a “Keep Glyphs” custom parameter and listed every character I wanted to keep. I excluded lowercase. For example:
    A
    B
    C
    zero
    one
    two
  4. Created a “Reencode Glyphs” custome parameter to give uppercase glyphs to the lowercase. For example:
    A=0061
    B=0062
    C=0063

#9

I pulled the font into TransType and noticed that the uppercase seems missing. When I open the OTF in Glyphs, there is only the lowercase unicode range. The glyphs are all uppercase. I get expected behavior in Illustrator, but I suspect that won’t be the case everywhere. What is the solution for copying uppercase over lowercase and not losing the uppercase? I want to create an instance that outputs an all-caps font. Is there a way to double encode with a custom parameter?


#10

I have tried to find a solution in various ways: renaming, reencoding, replacing lowercase with alternate caps, changing the order of the parameters. There are multiple ways in which the Mac displays them in Illustrator as I intend, but I keep finding problems when I view the font in other apps


#11

You need to add the Unicode of the upper and lower case in the ‘Reencode’ parameter (separated by a comma).


#12

Thanks. Like this?
A=0041,0061


#13

Yes.