Export doesn't work anymore– no error message (since last update?!)


the export of OTF files isn’t possible – Glyphs (Version 2.6.1 (1230)) act like it is exporting (showing the export-window) but after my folder is still empty, without any error message. After I tried to export once, the export window doesn’t appears anymore (until I restart the app) It just happen nothing.

The problem appeared the first time since the last update. I also tried to export fonts from older glyphs files to exculde that I cause that problem. But that also doesn’t work – so it wasn’t me. (think so) – If it would solve that case I would like to downgrade Glyphs, is it possible?

Please help me – it is very important for me because I have to deliver the exported font very soon (better tonight) :S aarrrg

Thank you & best regards

Do you get any error message?

Can you send me the .glyphs file?

The old version should still be in the trash.

I have exported a number of fonts already with 2.6.1, so I assume it is a local problem. Outdated plug-in perhaps? What happens in the Console.app? Any error messages in Window > Macro Panel?

The only Message I receive »Einige Glyphen sind nicht kompatibel und werden leer exportiert«
But I’m used to that, and that’s not the problem I think.

I’will send you my file – to which address?

oh no, stupid me, I already empty the trash :frowning:

I will checked the plug-ins and the console and while just opening the app:
AEGetDescData of non-desc type ‘reco’ not a good idea

while exporting this happens:
errors encountered while discovering extensions: Error Domain=PlugInKit Code=13 “query cancelled” UserInfo={NSLocalizedDescription=query cancelled}

Don’t know if something with my plug-ins is wrong? But everything is up to date

It will be labeled with Glyphs if it is Glyphs-related. You can type Glyphs in the search field in the top right.

In the meantime, his was the last build before the new makeotf version was implemented:

I will try to use your glyphs version, thank you for your super fast answers!

Looks like a problem with a plug-in.

Can you open that error message that says errors encountered? It will give youa hint as to which plug-in causes trouble.

I have tried to export OTF too and it does not work for me. I see no error messages and I have changed the family name of the font from font info now it works.

I can open the error message – but there is just the same message with no more information.
I already delete all plug-ins and now I will try to delete each extension one by one.
BTW – I tried it with Glyphs2.6.1-1220 but this also wasn’t working :frowning:

doesn’t work for me :frowning: thanks nevertheless

Now I deleted everything, I also restart the computer and the app. The console still showing:

  1. What happens if you click on Glyphs > Preferences > Addons > Plugins > Check for updates
  2. Does it work if you start the app with Option and Shift held down? (Disables plug-ins)
  3. Does it work if you empty out the Temp folder? Script > Open Scripts Folder, then navigate Temp, delete all its contents.


I tried all your steps. (first and secound without results)
But after I empty the temp folder, after the export failed again, I checkt the temp folder and I saw that the export stopped after exporting the first weights (instances).
Thats why I tried again to export fonts from older files ( this time without any problems) – so it looks like that my current file is broke.
But I still have no idea how to fix it. Can I send you my file, please?

the error message in the console is probably unrelated.

OK. Can you please send me the .glyphs file to support (at) (this website without www). I will have a look.

1 Like

For the record: the features were outdated, and makeotf aborted the export. But no error message was displayed inside Glyphs. Pressing the Update button in File > Font Info > Features fixed the issue.


Everything works now!
I’m soo happy :slight_smile:
You guys are awesome :man_dancing:

1 Like

Thanks, we will make sure an error message is displayed in the future.