Exported font stylistic alternates not working


I have been working on the same glyphs file and I was using ss’s features to test some alternate characters. The otf’s were working fine and all alternates were accessible in InDesign. However today I exported a new instance of the otf and even though the alternates (ss01 and ss02) work in Glyphs (compile and preview works fine), when in InDesign, I cannot access them. In fact, the alternate glyphs in the Glyphs Panel (InDesign) instead of displaying as Stylistic Alternates show up as NULL.

Things I tried:

  • Exporting the file from another computer with an earlier version of Glyphs (not cutting edge).
  • Renaming glyphs
  • Manually building the ss’s
  • Copying the same glyphs in a new file and building ss’s and exporting a test font worked fine.
  • Deleting font files, quiting InDesign, restarting the mac.

It seems that the Glyphs file is somehow corrupt. Any ideas of what might be causing the problem?


So I tried adding some other feature to the font (smcp) and it doesn’t work either. The .smcp characters appear as NULL too.

How did you instal the fonts? This sound like a font cache issue.

I exported them directly in the Adobe/Fonts folder as suggested. I also exported the fonts from another computer and the features were not working either.

Were the different fonts produced with different versions of Glyphs (2.3 betas) or are these all from 2.2?

Exported with Version 2.3b (885) from my mac and with Version 2.3b (848) from another mac.

Clean your temp directories, export the fonts in the two versions again, and compare the feature files to see if the code changed.

Cleane Temp. Restarted. Exported a new version of the otf. Still nothing works.
I compared the new otf with a previous version that worked fine in a text editor and in OTMLite and there I cannot see any difference in the built tables. The new file has the ss01, ss02 in the CFF table with their proper names (name.ssxx). The GSUB feature list has entries for both ss01 and ss02. But still. The features of the new font just don’t work.

Please send me the file.

If you remove all instances of the font from the Fonts folder, does it disappear in Indesign? Maybe you have an old copy lurking around?

I tried that. I also tried to use the font file in another computer and the features still don’t work.

Can you send me the .glyphs and the .otf file?

I sent the files to Eric. Do you want me to send them to you too?

If Eric has it, it is OK.

The Languagesystems were incomplete.Turn on the automation and it works again.

Thanks Eric. It did work indeed.