Exported TTF: some letters are not rendered smoothly

That was the issue, but ever since I fixed the issue, now certain letters in my font are not smooth anymore in certain applications. How do I fix that?

Do you use a grid smaller than 1?

I am not sure what that means. This is my first font so I am not too familiar with all the terms. Can you explain it a little more? Also, for more context, it works fine in Adobe Illustrator now, but when I use the font in software that creates raster images like Photoshop and Procreate I get those rough wonky edges.

Can you post a screenshot of the glyph in the edit view (that we can see the nodes)?


Can you send me that file?

The font contains some stored TrueType tables. Do you rely on them? Try removing them in Font Info > Masters > Custom Parameter > prep Table Assembly, fpgm Table Assembly and CVT Table.

Apparently you opened and reexported an existing TTF. Technically, this was pretty heavy reverse engineering, and some of the information that has been reverse-engineered is out of date now.

There is a tutorial about opening existing fonts. (It has been written for Glyphs 2, but the info should still apply for Glyphs 3.) It covers a few things to take care of. Many custom parameters are superfluous probably. And if the original font has been installed before, you will need to circumvent cache problems, best with the Adobe Fonts folder.

So I deleted the stored true type tables and I still has the problem. I’m not really sure what to do now, but thank you for all of the help.

The font works fine for me in Photoshop and Indesign and everywhere else.

Would that mean it’s a font cache issue on my end?

Possibly. Change the font name to be sure.

Useful tips on how to combat font cache problems: https://www.glyphsapp.com/learn/eliminating-font-cache-problems