Exported typeface different in Indesign and Illustrator

So I’m currently testing out my typeface, and I’m using both Indesign and Illustrator as I need it in both for a part of a brief I’m doing, and mocking it up for a crit I have at uni.

Exported the typeface yesterday, ensuring everything is compatible. The typeface looks great in illustrator, exactly how it looks in Glyph. In InDesign though the corners have been cut, so my rounded caps are three straight edges like half a hexagon. The smooth corners are now sharp corners where the corner nodes are. No idea what I’ve done wrong for this to happen.

Are you using the Adobe Fonts folder?

Yeah I am

Make sure you really are testing the same font. Put in something obvious, like a circle under your x to verify if that is really the same version.

Consider turning off hinting.

Double checked by re-exporting with a completely different name so it’s definitely the right font. How do I turn off hinting?:slight_smile:

I’ve tried exporting as OTF with autohint disabled and the problem is still there. The one before I exported as a Variable font but I don’t know how to disable auto hinting for that export.

There is no autohinting for variable fonts.

Which version of macOS and which version of InDesign are you running?

Cataline 10.15.14, and Indesign 15.0.2 so both up to date

Figured it out, and was nothing to do with the Glyph app. I had placed a stroke on the text, but then decided I didn’t want it so just put it down to zero, but instead of just disappearing, the stroke was still visible on the corners and making weird shapes behind it. Removing the stroke completely helped me.

You can see what I mean on these images. The first one has Stroke None selected, second with a small stroke, third is where it has stroke selected but the weights zero. The third is what was happening and the stroke and fill were the same colour so were appearing as if the corners had been cut.

Thanks for the help though!:slight_smile:

I reported that bug to Adobe and they think it is fine like this and deliberately didn’t fix it.