Exporting variable contextual alternates font

Hi all –

In the last version of Glyphs I made a contextual alternates font which was also a variable font (it was my first attempt at making a font and I didn’t have a lot of time, so I just made it and exported it, and to my amazement it worked!).

Now I’ve got the most up to date version of Glyphs and I’ve made another contextual alternate variable font in the same way, and I can’t export it. It keeps coming up with errors. At the moment it’s saying “There was a problem autohinting the glyph Z”. It did say that about “.notdef” too, but I took the advice from this forum and made a parameter for it to be ignored (unchecked Enforce Compatibility Check).

Every time I seem to address one problem it comes up with a different error about a different glyph, and I’m not sure what I need to do to correct it. Particularly as there are 4 variations of every glyph, so I don’t know whether the problem with Z is with regular, italic, bold or bold italic.

Thanks for your help in advance!

Scarlett

How many of your troublesome glyphs show a red triangle in the upper left corner in Font View, or a red bar at the top in Edit View?

None of them show a red triangle in font view. Is the red bar the same thing, or should I go through them all individually and check for that too?

Can you try to update to the latest cutting edge version (3.0.2-3050)?

From within the app if I check for updates it says I’m up to date, but it’s 3.0.1. Is there somewhere I can download the latest version? Thank you for your help!

You need to activate cutting edge versions in Preferences > Updates.

Ah! OK, thanks, I’ll do that now

The red bar is the same thing.

Righto, I’ve updated it and tried to export again, and this time the error reads:

Some glyphs are not compatible and will have no outlines (then it lists everything from A to Ecircumflex, which makes me think it’s a problem with every glyph in the font).

After that it says “Stems can’t be zero” - I didn’t do anything with stems last time I don’t think, so I’ll have to read up on that!

Can you send me the file?

Yep will do. Thank you! I’m a beginner so I’m sure I’ve done something wrong somewhere. To support [at]?

yes.

Sent, thanks!

If you try to export as a variable font, you should not add a “Enforce Compatibility Check” custom parameter and uncheck it. Because all your glyphs need to be compatible and that parameter is hiding the compatibility warnings.

OK thanks, I’ve removed that – but it’s still coming back with the same warnings. What do I need to do to make the glyphs compatible?

From what I’ve read of variable fonts, it’s best to have the same number of nodes etc between regular and bold versions, but with a handwriting font with contextual alternates that’s not really possible. Could you give me an idea of what I need to do to get this working?

The last one I made just worked without any problems, and I’m not sure what I’ve done differently.

This should help: https://glyphsapp.com/learn/multiple-masters-part-2-keeping-your-outlines-compatible (the tutorial will be updated for Glyphs 3 very soon)

I was reading that yesterday – I’ll go through them again and try and work out where the problems are. Is there any reason why my previous font (which was very similar to this) just sailed through with no problems? Has there been a change with the new version of Glyphs?

Hi Georg – Where would I find “fix compatibility” in the new cutting-edge version please?

I honestly don’t know where to start – because I drew my glyphs in Illustrator and copy-pasted them into Glyphs, there’s no relevance with nodes between masters. This worked fine last time with no problems, but this time every single glyph is now showing as incompatible and I don’t know what I need to do to sort it out. I’ve tried following the instructions on the link (correct path direction; tidy up paths) but it makes no difference.

As it’s a handwriting font, it needs to be considerably different between variants.

The ‘Fix compatibility’ is called Shape Order, now.

If you are just looking for the (almost) ‘mono line with rounded ends’ look, you
Might be better off with the tools in Glyphs. Draw a center line and apply the stroke thickness and cap style in the lower right. Making your outlines compatible might take longer then redoing it.

One thing I wonder is the difference in weight between the Regular and Bold master. Making a variable font that varies so little might not be so useful to the user.

Thank you – I’m still really confused by how I was able to make a workable font almost the same as this with no problems.

The context is that I’m a graphic novelist and I need to make a font based on my writing so my books can be translated into other languages easily (I hand write them usually), so it’s not got an end user in mind other than myself / publishers to replicate existing work.

Does this mean I have to start all over again? And why did it work in the previous version of Glyphs, has something changed?