Extra glyphs in Color Font open type (broken segments)

I made a color font of 376 glyphs (includes three alternates of lowercase and uppercase) which exported fine and the alternates cycle as they should when typing. However, in INDD/AI when I view Open Type to manually select an alternate, 1000+ more characters are available which look like broken segments see screenshot. How do I ensure they don’t export with the 376 main characters? I thought only the 376 characters showing in my Glyphs font panel would be exported.

You exported a COLR/CPAL font. That works by adding each color shapes as a new glyphs to the font. You can’t do anything about that.

If you need your font only in Adobe apps, you can instead export a SVG table. That will not add those extra glyphs.

Hi Georg, thank you for explaining. I opened the Export panel and selected/exported the top 3parameters, then renamed the file to keep it separate from the CPAL font >>

I also checked the SVG tutorial .
In Illustrator{tab Glyphs}, the SVG font is still showing the 1000 segments

Could you share the tutorial link so I can follow the correct export steps to avoid this?

Do I need to delete the CPAL font from my font book and Adobe, so that the SVG can be tested?

Yes. For testing fonts: Eliminating font cache problems | Glyphs
and Testing your fonts in Adobe apps | Glyphs

Thank you Georg, I stripped out all the caches, emptied bin, unticked COLR&CPAL for each active style, renamed font and exported, restarted, replaced fonts in Illustrator, restarted again, but the 1000broken segments are still showing. Then I found this forum chat advising others to make the glyphs as images/icons: PNG / SVG Export - #29 by dergraph
Is that what I have to do too?

This is my first font, which happens to be a color font, and I can’t list it for sale because of this. There must be something simpler to fix this i.e. that doesn’t require additional coding?
I followed these instructions:

Since Adobe apps only support SVG color glyphs, you can export pure SVG variants (i.e., without COLR+CPAL), and recommend those to Adobe users. If the COLR+CPAL particles are still showing, then there is perhaps something missing in the instance setup. This works for me:


1 Like

Thank you Rainer Erich, your check boxes look different to mine and to the Glyphs convertCPAL tutorial above. I’ll clear the cache again, re-export using your three blue tick boxes.

Just confirming that only one blue tick is required for Color Layers to COLR? No tick needed on the right side of COLR?

Yes. The first checkbox on the left is for activating the parameter. The second on the right is the Boolean value of the parameter.

Yes to tick the Boolean on the right side, like below?
…or is it Yes only tick the left box as I enquired (and shown in your screenshot)?
slightly confused sorry
Midnight here now so I’ll check/the forum again tomorrow :slight_smile:

For the “Export COLR table”, you need to check the left checkbox and uncheck the right.

The left checkbox is there to disable the parameter altogether. If unchecked, it is the same as if the parameter is not there at all.

Hey hi Georg, I’m referring to Rainer’s screenshot in his comment 3hrs ago (also shown below). He ticked only these two items >>

Now I’m really confused. Can you pls paste a pic below showing which boxes to tick to export a vector color font and avoid segments appearing in the glyphs panel of Adobe? It might help other people who need the same information. Huge thanks to you both in advance :pray:

The screenshot in your last post is correct.

Yes, sorry about the confusing UI of boolean parameters. In a future version of the app, we have a better solution.

In your case, you may want the Color Palette for SVG as well, otherwise you only ever get the first palette. I believe Export SVG Table is implicit if you have Color Layers to SVG, so you don’t need to set it explicitly.

The extra COLR parameters are superfluous if you turn off COLR/CPAL.

Thank you Rainer Erich. I cleared the cache, updated Glyphs, renamed my file, restarted, ticked the boxes you showed on 24Aug plus Color Palette for SVG on all five active styles, exported to Adobe Fonts folder >>

Opened Illustrator - chose Type - Glyphs. The segments are all still there. There must be a way to have them not show in this table?

Let’s schedule for a quick zoom session later this week.

I feel badly that I can’t see where I’m making the mistake. I will email you to check timezones