Failled to install plugin due to "write permission"

I’m using Glyphs 3. and got this.
System Mac os 10.13,

The app icon in the screenshot of Glyphs 2. Did you have the plugin installed before or was this the first time you installed the plugin?

I used img uploaded by others. But the message is same. This is the first time i use plugin, I 'm new user of Glyphs, bought this app just few days ago.

Can you check the application support folder. In the Scripts menu, you find “Open Scripts Folder”. Clicking it will open the Glyphs 3 Application Support folder. There you should find a “Repositories” and “Plugins” folder. What is in each?

nothing in plugin, and there is only a empty folder called “showinterpolations” under “Repositories”

Is Show Interpolations the plugin you are trying to install? In that case, please delete the empty folder and try again to download it from the Plugin Manager.

yes, but reinstallation does not work at all.

Deleting that empty folder should fix this.

does not work. is there any other way to solve it, such as downloading the plugin files and put them somewhere

You can download the plugin from GitHub:

There, click the green Code button and choose Download ZIP:

Then, go to your download folder, open the zip file and double-click the ShowStyles.glyphsReporter file. Glyphs will open (make sure it’s Glyphs 3 if you also have Glyphs 2 installed) and asks you if you want to install the plugin. Confirm with 安装:

Relaunch Glyphs for the plugin to be loaded.

We are looking into it this issue. Could you please select the Repositories folder and press Command-I to show its info and post a screenshot of that info window here? That might help us track down the issue. Like so:

In fact, it’s due to the GFW in China mainland. Your VPN is not reliable enough. When the https connect broken for some reason, the Git clone of the plugin manager will fail too. Then leave an empty folder (with .git info).

The robustness of the plugin manager is also not so good in my point of view.

1 Like

Interesting and good to know! I am not sure how Glyphs should best handle the Great Firewall, but since GitHub is involved in loading the package index and most of the plugins are hosted on GitHub, this issue might not be trivial to circumvent.

You can host your own package index (see Using Private and Local Plugin Repositories), but the download of the plugins will still access GitHub for most of them since most plugins are hosted there.

Yes, we made our own mirror server for the plist and all the repos. But still fighting with the network complexity here. Some code polishing or server change will be made in this week. Not ready for public yet. :face_with_head_bandage:

Is there anything I can do as a plugin author to make things simpler? I currently host three Glyphs plugins on GitHub.

I have added a mirror of the main package index to my personal site at It adds a dragon head after each title to differentiate the mirrored items from the regular items. This mirrors only the index, not the plugins, so I am not sure how helpful it is. Maybe I can add plugin downloads at a later stage.

thank you

Thank you. After manually installing this plugin, glyphs requires to install python, while i can not install it from plugin manager ( due to Great Firewall) either. Can you tell me how to install Python manually, pls?

Download the installer from Then you need to install pyobjC. I usually use pip3 install pyobjc in the terminal. But that might not work. Then you would need to manually install it according to the this page: Installing PyObjC — PyObjC - the Python to Objective-C bridge

After that, restart Glyphs and check if it picks it up in Preferences > Addons.

thanks, i will give it a try tomorrow.