Fill preview not working

Whenever I press the spacebar, the glyph and handles entirely disappear with no filled preview in any glyph. Glyph paths are closed. Any suggestions on what to fix? I’m running Version 2.6.6 (1346). I updated today to see if the Fill Preview bug was fixed.

Here’s a screenshot of my View menu so you can see that Fill Preview is (√)

Can you send me the file. And a screenshot of the full window?

I also tried creating a new file and had the same problem.

no preview.glyphs (8.5 KB)

Can you start the app without plugins by holding down the Option and Shift key?

Thanks for the suggestion. I’ve quit the app and relaunched the app holding option and shift and still had the problem.

What exactly is wrong in the screenshot? What do you expect instead? The preview at the bottom shows as I would expect it, and I cannot find anything unusual in the Edit area.

@mekkablue - I thought when I used to press the spacebar, the top view switched to a filled preview.

Here’s what I’m seeing with a live recording. (1.4 MB)

It works for me in version 2.6.6 [1346]. In the movie clip yours is showing black paths. What version of the OS are you on?

Mac OS Catalina

I kind of suspected that. Do you have an older one to try it on?

Good suggestion. And thanks for your help. No I don’t have an older alternative OS.

Not yet able to reproduce on macOS 10.15.7.

When you start without plugins (holding Option and Shift keys while starting up). When that works, the View menu should be much shorter.

You could also try turning off some of the View options to try to narrow down the cause. Mostly the ones below the line after View > Fill Preview. It also looks like you have Speed Punk enabled (or something similar showing the curvature), though Speed Punk shouldn’t cause this issue. The only other thing that comes to mind is some kind of Dark Mode interaction.

I guess I wasn’t holding the Option and Shift keys hard enough the first 5 times I tried it. :wink:
When tried the 6th time it successfully disabled the plugins, and the space-bar preview functionality returned. I wonder which plugin started causing the issue.

Thanks for your help!

You can remove one plugin at the time and restart Glyphs.
But start by disabling SpeedPunk if that makes a difference.