Filter list and yehFarsi glyph names

Using Glyphs 3 (3055), but not new to this build…

I have a list filter with 88 glyphs, all of which exist in the font. The list filter indicates 73/88 glyphs exist, and right-clicking on the filter name shows 15 names which the filter thinks are missing. The names shown in the missing glyphs popup are all of the form yehFarsi…-ar.fina/.medi/.init, whereas the glyph names actually listed in the filter (and the existing glyphs) are of the form yeh…-farsi.fina/.medi/init.

The 15 listed as missing are:


The isolate forms are recognised fine by the filter. The yeh…-farsi isolate forms are listed in GlyphData.xml as altNames, and so are still recognised, but the other forms are not listed.

If I understand this right, there are two issues: the missing glyphs popup isn’t reporting the names as used in the list filter, and there are some entries missing from GlyphData.xml.

Thanks for Glyphs 3 - really enjoying the new features!

Can you send me the .glyphs and you list filter file?

Sent to support at this domain. Thanks!

Fixed it. Thanks for the file.

That’s great, thanks Georg!

Is this fixed? Having a similar problem with the standard Farsi list in the language menu, i.e. filter doesn’t match generated glyphs. Same with Farsi/Urdu numbers.

(New file, Glyphs 3.0.3/3065, no custom GlyphData.xml).

Thanks for pointing this out. I fixed it.

1 Like