Final version of Glyphs 2.3 available

We just uploaded the final version of Glyphs 2.3: New in Glyphs 2.3


Great, thanks Georg, looks very good.
btw, Glyphs app now starts an 'unknown service, port 8082’
I guess I should allow?

It is a small web server that allowed preview of TrueType hints in a browser. Open a browser in a virtual machine and type the IP address of you Mac plus ‘:8082’ like you will get a self refreshing waterfall of the current text from the Edit view.

1 Like


  1. The short keys doesn’t work anymore, if I want to switch between H and Z (Hand and Zoom), it only works the first time, and then it stops, every short key stops working.

  2. And why doesn’t preview follow the Master’s anymore?

Thank you very much for making the arrow key movement fit the grid subdivision, a really great improvement, thanks!

  1. Before this update holding down ctrl + alt while adjusting a handle would make the handle on the other side of the point relate and move as well, not anymore, why not? I liked that feature.

(Please excuse) I’m not able to see the smart filters !

I love the smarter panning in the preview pane.

1 Like

Did this address the crashing in El Capitan? I don’t see anything specific about it, but know it was actively being addressed in the beta phase.

You mean the positioning? Right-click in the Preview area > Always Center Active Glyph.

No, when I have a project with fx. 3 Master’s that I can switch between cmd+1, cmd+2, cmd+3, now the preview doesn’t follow that flow, so when I work on the Bold weight, the preview show Regular, doesn’t make any sense to me.

Hi Team, Has there been any change to the way instances are handled? I installed the update and reopened my file and my weights have gone awry. I’m designing a bold and light with the regular interpolated. The light and regular have become super heavy.

Hi again, I deleted the instances and added them again for both masters (Bold and Light). I made sure the custom parameter in the Master and Instance settings matched (Light =1 , Bold=3) and given the interpolated Regular a value of 2. This seems to have fixed it.
I’m not sure if I’m using the custom parameter correctly as I can’t find much detail on it in the manual.
Strange that v2.3 didn’t like the way I had it working in 2.2

Do you have selected a instance in the lower left of the preview? There is a popup button, select the - and it should follow the selected master.

The code that calculate the instances was changed. You might had bad values in the Weight or custom fields.

1 Like

Thanks George! Yes, must have been my custom fields.
From my description, does it sound like I’m using them correctly now? I was just relying on width and weight for this simple interpolation and haven’t got to grips with how this custom field operates.

It still doesn’t follow the master’s, see pics.

PS. The external ‘open corners’ and new reconnect nodes are awesome! Well done.

if you select the “-” in the popup it shows the current master.