Font can be selected in MS Word, but text does not change

Someone is having trouble with a font I made. They are using Windows 10 with Microsoft Office 16. In Word, my font name shows up in the font menu, but the text doesn’t change to look like my font when it is selected. The font works fine in other apps, like Notepad, so it has something to do with how Word handles fonts. I made sure all glyphs are present for windows-1252, and regenerated the font. They are still seeing the same problem. Is there something else I can try?

That usually points to a weird Unicode assignment. Make sure Font Info > Other Settings > Custom Names is OFF, select all glyphs and run Glyph > Update Glyph Info.

Do you have any extraordinary Unicode range covered? Emojis, PUA?

When I ran Update Glyph Info, there were several glyphs that were updated. I hope that is the fix. Thanks!

I thought that would work, but apparently not. I had a few missing glyphs, and a few that needed renaming. I’m not doing anything fancy with glyphs: no emojis or PUA. Unfortunately I don’t have access to the machine. I had them uninstall the fonts, reboot their machine, and install my newest files. I don’t have a way to identify what steps are really taken. Is there a font validator that would tell me if the font is out of spec with Word?

There is


1 Like

Thanks Georg,

I ran FontValidator and found some warnings and about 30 rows of errors under the GPOS table that look like this:
The AnchorFormat field is invalid
LookupList, Lookup[2], SubTable0, BaseArray, BaseRecord[7], BaseAnchor[1], AnchorFormat = 91

Each row is identical except for the BaseRecord[x]. I tried to use OTM to see what it’s referring to, but I’m still in the dark. I’m not sure what “AnchorFormat = 91” means. It seems like the problems are referring to anchors and mark attachments, and if I’m reading the table correctly, each error is associated with a glyph: “C mark attachment positions”, “Ccedilla mark attachment positions”, etc. There are no errors with with marks on A, E, I, O, U, or a, e, i, o u. The ones that get flagged with errors have values of zero for XCoord and YCoord in Class 1. Resetting anchors in Glyphs doesn’t fix anything.

The Microsoft documentation for GPOS is long, and I don’t really know what I’m looking for. How should I approach fixing the errors?

You can most likely ignore those anchor format errors. They show up for all fonts. FontValidator is not up to date with the latest OpenType.