Font Categories

I have a font with a lot of special characters, that usually don’t exist in normal typefaces. I would like to categorize them, to avoid having hundreds of characters in the category “Other”.
Is there a way of creating new categories in Glyphs app?

1 Like

What kind of characters do you have in mind? Can you give some examples?

I have a lot of drawings and shapes, for example I would like to make a zoo, so one category would be “animal” with glyphs named:
zebra, lion, monkey, horse ect…

an other group could be plants:
grass.001 grass.002 grass.003 flower.001 flower.002 ect…

This is an experimental approach and not a classical typeface, I will have so many different unusual characters, that I would like to structure them in a logical way. I also don’t want to place the drawings in normal characters, since i will have an alphabet as well.
Is this kind of understandable?

But how do you encode the glyphs? Do they get PUA unicodes?

What you would do is to setup a custom GlyphData file and assign an existing category to your glyphs. In this case it would probably be “Symbols”.

Instead of categories, you may be better off with simply adding List Filters.

@Georg: Yes, I do use PUA unicodes and I just manage to give my characters a new category.

I came across some problems:
My new characters now appear in the category “animal”, but they still don’t seem to have a unicode. In the “GlyphData.xml” I made two new characters with unicode E0000 and E0001, but in Glyphs they don’t have that unicode. The unicode info in Glyphs is just: -. Where do I set the unicode for a character in Glyphs?

The other thing is, the new category does not show up on the left side of the glyphs interface, where all the categories are listed. they only get sorted in the main area. Is it possible to update the list on the left too?

These are not valid. They should be E000 and E001. Can you paste the lines from your XML?

Setting the Unicode value manually: Check Don’t use nice names in File > Font Info > Other settings and then select the glyph in the Font tab and change the Unicode value in the respective column (List view) or the Unicode field in the bottom left of the window (Grid view).

Animal is not a category. Symbols is.

My corrected code looks like this:

What are the available standard categories and subcategories that I can use? Is it possible to create my own subcategories then?
Since I have a lot of “special” characters I would like to structure all characters in a logical way.

Will I get any problems, when I export the font and still use my own categories, like “animal”?

Please read through the tutorial Georg mentioned above. You will find all answers and a detailed walk through there.

I carefully went through the above mentioned tutorial to created my own xml. My project is a bit out of the norm, so placing all the my special characters in existing categories like “symbol” or “other” would keep the Glyphs overview untidy. That’s the reason I need to work with my own categories.
But what happens, is that even though in my xml, I define characters to the same category, they show up in different windows in the Glyphs overview. Here a screenshot to clarify:

Is there a possibility to make the character “car.001, car.002, bob.001, bob.002” show up in the same window in the Glyphs overview?
I know that there are filter lists, but I would also like to keep things tidy in the Glyphs overview.

Here is how my xml code looks like for the mentioned characters:

I hope there is a solution to that?

You have defined the names bob.00X and car.00X. But then you use the names car.shit.00X. You can add a suffix but not something in the middle of the name. It should work if you call them car.00X.shit.

Thanks for pointing out the naming mistake. That was one problem.
I have an other one… Somehow the alphabetical order seems to break the categories.

The characters “dirt, fossil, leave, time” are all in the same category according to my xml, but they are interrupted by “explosion” and “splash”…
Is there any solution for that?

Can you send me the xml and the .glyphs file.

I sent both glyphs and xml files in an email. I hope there is a solution for this?

You could use the sortOrder attribute like this:


… and so on.

Thanks for the files. I could fix this.

@georg: how did you fix it?

I had to change the code a bit. It will be available with the next update.

Hi Georg
I just updated to the latest version 1.4.4 (588), but still have the same ordering problem. Is there anything else I need to update, or will the problem be fixed in the next version?

Any solution yet??