Font information page will be open when opening a file

font information page will be open when opening a file, annoying, how to disable that

You mean the File > Font Info window?

This may be due to the system setting Desktop & Dock > Close windows when quitting an app:

this does not work for my pc no matter this option is selected or not.
This did not happen before. I found this problem when updating recently.

Also experiencing this, why should the system setting change if the behavior was not present before? Besides, it also happens when a file is closed and the app itself is not quit.

It shouldn’t do that. Was the window open the last time you saved the file?

No, and every time I open a random file another font info window is open too.

Happening to me too, but so far only when starting a new font.

What tab is it showing when it opens?

I have a similar issue, the opened tab is "Font?

You mean in the Font Info window? It’s just the first one, Font.

I tried the cutting edge version and it happens to me too.
When opening an existed file, the Font Info and Start Window are also opened.
Glyphs 3.2 (3205)
macOS 10.13.6

Does this happen with a new file, too? When you make a new document and when you save and reopen it?

yes. for both new and existing files

1 Like

Just noticed some difference on 3.2 cutting edge version:

  • The Font Info dialog no longer appears when opening a file (when the application was closed and I open the file).
  • Just Start Window still appears.

I made a new document as Georg mentioned, saved, closed Glyphs, and reopened this document. No difference from an existed documents.

I found that the window seems to come up, if you double click the file to open it (instead of opening the app first).

You can disable the start window by unchecking this checkbox.
Screenshot 2023-09-27 at 12.53.28

You should get that page of the start window when you open it from the window menu.

My Start Window doesn’t have such an options for a some reason.
I opened the Start Window from Window menu and there is just “Create file” button but not any options like “Show window on startup” on your screenshot.

Is it possible that you have disabled the File > Open Recent menu? If you open it, are there any entries?

1 Like

Exactly, this is a reason!

So I opened macOS System Preferences → General → Recent Items, and changed None to 5.
Opened one of the projects in Glyphs and closed it.
Restarted application.
And then the checkbox “Show window on startup” appears on Start Window.

Thank you very much for the help.