Font installing as duplicate even with a name change

I create a variable font exported it and installed it on my mac. A few months later I’ve had to make some tweaks to the font so tried to save it as {fontname}v2.

When I come to install it, it is saying that the font is a duplicate.

How do I export this as a new font that fontbook won’t recognize as a duplicate?


There might be several place where font names are defined in the .glyphs file. Have you updated all?

‘Family name’ is the only place I can find where it is named.

There are also names in the Exports tab of the Font Info window.

They’re all just standard style names as far as I’m aware.

Uninstall the old version, reinstall the new version, restart your Mac and hold down Shift to delete caches, restart again without Shift.

Or, change the file names.

Why? This is why:

I’ve tried changing the name but it still says it’s a duplicated font.

I’ve changed the file name and the font family name. Is there anywhere else it would need to change?

I would like both versions installed, so I don’t really want to uninstall the first version.

What name does it show when it complains?


can you check both files and see if the postscript Name and font Name in the name table are different?

Niether have a postscript name. They just have font name.

Can you show the dialog that telos you it is a duplicate? What exactly does it say? And did you make sure your new version has not been installed multiple times yet?

What exactly is the change you made to the name? What was the name before and what was it after?

It does seem like that in the Clara Legal-Mac font there might be a name value of Clara Legal. Earlier, you mentioned renaming with adding v2 to the name, but that is not shown anywhere in your examples. If changing the Family Name to something entirely new doesn’t work, then there’s a parameter somewhere likely still set to Clara Legal.

In addition to looking through the parameters in the Font, Master, and Exports tabs of Font Info (Command-I), you could look at the name table of the compiled font file to see where that name is set via FontTableViewer or DTL OTMaster, both linked on the Tools page or ttx (part of fontTools; also included in the AFDKO tools).

I changed the name from ‘Clara Legal’ to ‘Clara Legal Mac’.

You can see in the screenshot below that ‘Clara Legal’ is installed and when installing ‘Clara Legal Mac’ It throws up the error.

The font family name has been changed and I can’t find ‘Clara Legal’ named anywhere else in the file.

I have tried changing the name completely and the problem still persists.

The version has not been installed multiple times.

How have you checked the font for the remaining font names?

If it has anything to do with the font itself, then take a look inside the compiled OTF with FontTableViewer or OTMaster. You can compare both the original and the new version side by side.

Can you really exclude you did not already install the OTF once before? Can you open the triangle to display the individual fonts, and reveal them in Finder.

Thanks for your help. I seemed to have solved the problem.

If I rename the instances in exports then it seems to solve the problem.