Font issue in Windows 7

I’m wondering if there is any tool/software on the market that can help to understand a font issue that does not displayed correctly on Windows 7? Will OTMaster be able to help with this?

This is the issue:

Never seen this before. You could compare in OTM, sure. But have you verified it is not a cache or naming issue?

I don’t think it is cache issue - it was tested on three different Windows 7 computers.
The font work (at least they’ve tried it in MS Word and Illustrator). The only issue is that Windows itself doesn’t display (preview) it correctly.
OTM shows some issues in naming
I have tried replacing Regular with Bold but it doesn’t seem to solve the problem.

And here:

That seems to be a naming problem. Can you try not to abbreviate the style name?

Tried that - didn’t help.
Here is what I’ve tried: deleting all the functions or unicode values from the private area - both didn’t help.

Deleting all alternatives (keeping only the simple forms of the letters) solves the problem (no change in naming) - Windows 7 preview shows the actual font.

There are 6 fonts in the script subfamily. The Regular one works fine with the Win 7 preview. But both Light and Bold have the same issue - they are being displayed as Helvetica/Arial. So would guess that naming is the case but why the “short” version of the two fonts works fine with the same naming then?

I’ve figured this out. There was a 4-letters ligature in the font. Removing it solved the problem.

1 Like

That seems odd to me. Such a ligature should not prevent preview. Have you tried putting it through the MS Font Validator?

No, I haven’t tried MS Font Validator.
It’s not because it was 4-letters. It’s probably because it was nearly 7000 units wide :slight_smile: There must be some limits…


Oh, that explains a lot. :slight_smile: Thank you for letting us know.

Glad you solved it.
After several years of working for, and with, Microsoft, this dumb stuff still makes me cross. I had the style name length issue recently. Perfectly within OT standards but not MS’s

Microsoft: Putting technical limits on everything since 1974.

@Ginjam, I’m wondering if there is an online source where I can read about all their opentype “limitations”?

I have some issue too! what is solution? Could you explain what is a “4-letters ligature” and how to delete it?

Check for a glyph that is very wide. E.g. sort by width in list view. And disable it.

Ok. which width is suitable and which is not?

They don’t appear to be overly wide to me. But try anyway to disable all glyphs wider than UPM, and see if that changes anything.

What is UPM?

File > Font Info > Font > Units per Em, probably 1000.

Your font not showing up in Window may be cause by something else, not necessarily by a wide glyph.
Try disabling all alternates and export only the main set of letters. If this solves the issue, start enabling additional characters one by one or by “sets”. If the base character set still gives you the same result (font is not showing up in window) it’s not glyphs that cause the problem. It may be naming or something else.
Is the font handwritten/traced or digitally created?

1 Like

Yes, what Elena says just reminded me of the MS Font Validator. It will sometimes spot issues that help fix woes in Windows.

I found solution. Simply open .ttf font on FontLab and export it