Font not showing in After Effects

I’ve been working on a 2 axes variable font that’s been working fine in Indesign and Illustrator so far during testing. I wanted to try out this new font script for animating variable fonts in After Effects but i’ve just noticed that the programme doesn’t seem to recognise the font at all. It seems to be having the same problem not recognising it even with a non-variable oft export of it.

Any pointers on what might be going wrong here?

How do you install the fonts, into the Adobe font folder? Some Adobe apps don’t look there so you would need to install it system-wide.

Yep it’s installing into the adobe fonts folder. I think After Effects should be able to pull it from there as there’s other fonts I’m working on (also variables) that do show up there.

However, I’ve also tried installing it onto the wider system and it doesn’t show up either.

Can you drop the file onto fontbakery.com and see whether any errors are shown? Look out for issues related to the name table, most of all.

Wondering if any of these errors might specifically stand out as being problematic? From what I can tell, they don’t seem to relate to the name table? Wondering which ones might be the best to focus on in terms of trying to resolve the problem.

Do static exports of the font show up in After Effects?

No, static versions don’t show up either.

Actually, just looking at this again, it seems the static otf’s of the same font do show up and all weights are there. However the variable ttf is still not showing up.

Does After Effect support OTVAR at all yet? At least the origin should show up though. Do your variable fonts have different family names (from the static ones)? If not, there may be a simple font conflict.

To update: I got this working in AE by including an underscore in the Family Name. Feels like a kind of messy solution though.

Is anyone able to shine light on why this might be?

Possibly an installation issue. Hard to say unless you do testing in different users, different machines.