Font size: how do I make the whole font set bigger?

My font is much smaller than regular fonts. I need to make the whole thing bigger all at once, but I can’t seem to figure out how to use the units per Em correctly. When I type in 80o it gets smaller, when I type in 1200 it gets smaller.

I created my font at the following metrics:
Ascender: 623
Cap Height: 615
x-Height 500
Descender: -23

I need it to be double the size.

Easiest way is to change the UPM (Units per Em) value in File > Font Info > Font to a smaller value. Do not use the Scale to UPM parameter, which does something different.

800 must have made it bigger. If it displays smaller, then something else went wrong.

1 Like

How do you test the font?

oh got it - I was changing both of those. It’s all fixed now!