Font Validation Errors

I have a font that is giving me font validation errors when trying to install it in Fontbook. I think it’s because it’s a super gritty / textured font. What can I do to reduce the number of nodes easily or identify what may be causing the issue?

Happy to send the file if it helps. Thanks in advance!

Do these validation it was a peer at installation, i.e. when you open the font with font book? Did you install it before? Then you can often ignore the first validation errors. Repeat after installation (right click its entry in font book, pick validate from the menu), and see if the validation error persists. Also, at that point, you will usually get a more detailed report, not just OK/not OK.

Hi @mekkablue Yes. The error appears before and after installation. I have not installed the font before. Attaching an image of the extra report fontbook gives me.

Try turning off autohinting (i.e., uncheck Autohint in the Export…OTF dialog window). There was a past rumor that Font Book would have issue with a large number of hints. Hope that helps.

Good suggestion! I read this in another thread and tried it to no avail. At this point I think it may have something to do with the gritty paths I’ve drawn in the font? No idea…

That could, perhaps, be the case: large number of nodes/paths. Another option to try, though I suspect it may not help, is to set the Disable Subroutines custom parameter for the instance.

Perhaps the ftxvalidator command-line tool from the Apple Font Tool Suite might report more about the issue? If not already installed, it should be available from:

Yes, there are a few problems with complex outlines like these.

  • In CFF (PostScript-OTFs), many small curve segments pose a performance problems for the renderer. See if you can replace them by straight segments. Try the Retractor plugin or the Roughen filter, or try TTF.
  • Make sure there is no hinting info left in the font: no Autohint option at export (consider an Autohint=OFF parameter), and run the Delete All Hints script from my repository
  • In CFFs, you must disable subroutinization with the parameter of the same name.

Much thanks for your help and time troubleshooting this. I’ve renamed all questionable glyphs.

-I’ve followed the instructions for installing and using the Retractor plugin but it’s still not showing under Filter>Retractor. Have restarted Glyphs multiple times.

  • I’ve run your script and added the parameter to no avail… unless I’m just really doing everything wrong.
  • Have no idea what disable subroutinization means. Is that a custom parameter?

Last question. Assuming something is wrong with the paths in some / all of my glyphs, how can I troubleshoot this? Anyway to determine what glyphs, if any, are causing the font validation warning? Much thanks!

Well. I’ve solved it. Not sure why this worked, but it did. I simply created a new glyphs file and copied / pasted my existing glyphs into it. It’s exporting fine and no longer triggering a font validation issue. So strange, but I’m just glad it’s now working.

Can you send me both .glyphs files?

I am experiencing a similar issue with a file. Tried all the possible solutions on this thread with no luck. I want to try make a new file as @angie reported. Is there any simple way to copy all glyphs into a new file?


Just tried making a new file by copying all glyphs but the validation error persist. I believe is a drawing problem or too much nodes… Font installed anyway and works just fine in Adobe apps. When I did a new validation using Font Book App, the same problem appear, just say System Validation, no any specific error.

Do not trust the validation of Font Book, it is very buggy. Most validation errors are triggered by the way the font is installed, e.g. if you double click a font from within the Adobe Fonts folder, Font Book will tell you the font is broken. If you drag the file on the desktop first and install from there, you don’t get the error.

Yeah, might be something like that; I’ve tried to install on another computer and works just fine.