FontLab import of Glyphs 2 file


Noticed this week that when using the Python import script to import recent Glyphs 2 files, it skips over composites. It is OK when I open and safe the file with Glyphs 1. It is also OK with Glyphs 2 files saved about a month ago.

Comparing the files in a text editor, to see what is different: In the old files all components have a transform, in the new files the first component of a composite does not have a transform.

Best regards
Jelle Bosma

I ran into the same problem last night.

I’ll fix the script.

Please get the new version.

I also ran into this problem (I think — it happens with all Glyphs 2.0 files) and downloaded the latest version (july 11, 2015) of the scripts, but I still get this error message for all component characters:

There was a problem reading the components for glyph: ibreve

can you send a .glyphs file that does not import? It works for me.

I figured out the problem. It was to conflicting versions of the script on my computer. The updated version work as expected.