Fontmake export stopped working for glyphs 3

Hello, I have noticed that Glyphs3 to ufo/fonts is stopped working. It still works for Glyphs 2.
I upgraded Glyphs3 to the latest version as well as font make, Glyphslib packages but I’m constantly getting the following error:

value._parent = self._owner
AttributeError: 'str' object has no attribute '_parent'

I assume it’s something simple I’m missing. If there is a fix I can apply I would be very grateful to hear the it. Thank you in advance!

You could give this a shot:

Thanks that looks cool. However I’m not seeing the option of exporting UFOs, exports fonts directly.

The support for Glyphs 3 files in fontMake (glyphsLib really) is spotty.
Can you send me the .glyphs file that I can have a look if that can be improved. Or you could add an issue in the glyphsLib repo.

Hi Georg, thank you for jumping in on this. Here is the file (however I tried on multiple files). Additionally, for this specific file, I’ve tried to revert by saving it as glyphs2 and running the Font.previewRemoveOverlap = False in the macro, but the remove overlap preview flag is still there so I can’t save it as version 2.

I just tried and the latest version of fontmake does work fine.

Can you check what versions of fontmake and glyphsLib do you have. And how do you invoke it?

It is very likely there is something on my side.

My fontmake version is 1.5.1, glypsLib is: 5.2.0

In the terminal, I call: fontmake -g Szym_Rm.glyphs -o variable (or any other format)

I just realized the glyphsLib haven’t been properly updated and is way behind, I upgraded to 6.3.0 and everything works.