Fonts exported to /Library/Application Support/Adobe/Fonts/ do not show up in Adobe apps

I’ve tried restarting the apps and the Mac itself. Can’t find any duplicate otfs in library/fonts that might be screwing this up.

Running Version 2.3 (895) on OS 10.11.6.

FWIW, this is a brand new computer. This worked fine on the old one; it broke when I transferred my files to the new machine.

Thanks in advance for your help.

Just to note that I’ve been getting this too, but I think it might be Adobe. I have also changed machine, but there has been a major update to the Adobe apps recently.

I had some reload problems in CC 2017 recently but it worked eventually. I will have a look if I find a pattern.

I would appreciate that, Georg. In the meantime, do you have a workaround? I’m afraid I need one very soon; right now I can’t proof, which means I can’t work.

Some things you can try:

  • Clean out the fonts folder. Maybe there is a file that Indesign doesn’t like.
  • Try one of the other Fonts folders. There are several, I have the best experiences with this: /Library/Application Support/Adobe/Fonts/. But there is one in the user library, several in the Applications folder (one for each app).
  • Make sure that you have write permissions in the folder you exporting into.

I’d rather not dump out all my font files and have to reload from scratch if I can avoid it. But I’ll try one of the other font folders, including Adobe ones. Meanwhile, I’ll wait to hear. Thanks!

Maybe just move the fonts to the Desktop to test it.

Did you uninstall and reinstall all of CC? In my experience Adobe software installs don’t transfer to a new mac correctly.

It is. of course, now working for me. I didn’t do anything!

@Georg: I don’t understand. Move them to the desktop how? Move the Fonts folder there?

@James: Thanks. That does sound promising. I just hope I can get the right build of Illustrator back. The newest one’s useless.

Uninstalled & reinstalled CC apps. No joy. Oh well.

Right now I’m putting fonts in a users/maxphillips/Library/Fonts alias, and then using the latest FontNuke to clear the caches. So I can work again, but it would sure be nice if I didn’t have to keep restarting.

Yes. Or rename it to Fonts Old and create a new, empty one called Fonts.

Thanks, Rainer.

I’m just trying to test some fonts in Indesign and it seems to load the font just time but Indesign takes ~10s to respond to each mouse click. That is a very fluent working experience like this.

What helped a little bit was restarting InDesign with Shift+Ctrl+Alt+Cmd held down (yes, all four of them), until it asks you if you want to delete prefs. To be on the safe side, restart the Mac twice: first with Shift (safe mode, clears caches), then without Shift.

Thanks, Rainer. I’ll try it. Thought this isn’t just an InDesign problem; Illustrator, too.

Georg, I’ve given InDesign and Illustrator a lot more than 10 seconds to load the new font.

The loading of the fonts was quick, but the App froze as soon as I selected something. Resetting the preferences did help a lot.

Did you check it the fonts are actually copied into the fonts folder? Maybe the file permissions are messed up? The easiest way to test this is to restart Indesing and check if the new version shows.