Fractions feature

I’m trying to use the ‘Tal Leming’s Fraction Fever’ as outlined in the Fractions tutorial

It seems to work perfectly except that the space is not being replaced by my thin space glyph. E.g. in Indesign or Illustrator, I type ‘3 1/2’, select it and apply the fractions opentype feature. The fraction is created, but there is still a standard space rather than a thin space between the 3 and the fraction.

Any ideas where I’m going wrong here?

I cannot reproduce this. Works as expected in AI CC for me.

Is your thinspace alright? Maybe the width was not set yet in one master, and the interpolation is too wide?

How are you testing your font? Are you using the Adobe Fonts folder?

Thanks. My thinspace appears to be set up fine in both my masters, significantly narrower than my standard space in both cases.

Yes, I’m indeed using the Adobe Fonts folder for testing.

Can you send me the .glyphs file? support (at) (this website without www)

Thanks Rainer. Just sent you an email.

I had a look and it actually works fine in AI The difference between your space and thinspace is not very much, so one would not notice the difference at first. So I put a little dot in the thinspace in order to see which one it was, and it was just fine:

That’s baffling because I’ve just tried the same thing and I still can’t get it to work. Could it be something up with my Adobe apps?

Most likely a font conflict. How did you install the font?

I’ve just been exporting from Glyphs to the Adobe font folder the whole time.

try to change the font name. There might be a different version of the font floating around somewhere.

So I changed the name in the font info, exported it, deleted the previously named files from my Adobe font folder and rebooted my MacBook and it still hasn’t fixed it.

Seems I must have overlooked something really simple. Am I making a fundamental error in Illustrator when using the opentype fractions feature? To clarify, I type: 3 [space] 1 / 2 then select it all and hit ‘Fractions’ in the OpenType panel. Figure and Position are set to default.

[quote=“IainHector, post:11, topic:2448”]
To clarify, I type: 3 [space] 1 / 2 then select it all and hit ‘Fractions’ in the OpenType panel.[/quote]

That is exactly what I did, and it worked without a hitch.

What version of Illustrator do you have? And can you try Indesign? Illustrator sometimes doesn’t reload the fonts correctly and is a bit picky with OpenType.

Mystery solved (sort of). I’m running CC but I tried it in an old version (CS6) of Indesign and it worked fine. Thanks guys.

For some reason now I have this problen in InDesign CC, where I select everything, apply the Fractions feature and get ³ ¾ instead of 3 ¾ … frac feature is auto generated in Glyphs.

That is expected behaviour for the default code. If you want a smarter code that tries to detect standalone figures, see Tal Leming’s ‘Fraction Fever’:

See and

Ah, okay. I thought this lookup was supposed to be built in the automatic feature generation. Thanks!