G3 [3072] crashes every time I press cmd + z


This is a really unpleasant problem as I am not able to undo my action. Is it the new versions problem?

That is not a new problem. How quickly can you trigger the crash. If you can do a screen recording of what you do from the beginning, I might be find the trigger. And please send all crash reports (the ones that come up when you restart the app).

Well, I just press cmd + z or I go to Edit > Undo and it crashes. I am not sure what you want to see on the screen recording. It happens no matter what I do before.

Does it happen even if you start without plugins? (hold down opt+shift at app start)

You have to do something because it is not crashing for me. So I need all information that you can give me. Can you try to start without plugins as @mekkablue mentioned, make a new document and try if you can undo, there.

I don’t always get crashes when I undo, but they’re certainly common enough to be annoying. I haven’t figured out what sets those cases apart from those that don’t crash.

Since the latest Beta (3072) G3 crashes each time when I undo. This happened also quite regularly in previous Betas but not each time.
It affects not each file, but unfortunately the ones I have to work on. New documents work fine, other G2 files opened in G3 and converted to G3 format also work ok — but not the problematic family. So I tried removing all custom parameters and features, as well as all plugins, scripts and modules … but no changes.
It’s always the same: start G3, open the file, open a glyph, delete one node, undo — crash (have sent all reports, macro window doesn’t say anyting).

Have you tried without plugins?
And can you send me the .glyphs file?

Just sent to support.
First I tried starting G3 without plugins and then even tried deleting all plugins, but nothing helped.

We could solve the problem by resetting the preferences. I’ll have a look at the preferences file to see if I can find the cause.

Sorry for my late response. I found out that it happens in a moment when I open a certain file, so exactly as Legilux says. I am going to send you the files too just for the sake.

I think I have fixed that. I’ll upload a new version in a bit.

Edit: new version is up.