G3 can't download python

I tried to install python through G3 menu “Script → install python”, but it always feedback that it can’t open the file “packages.plist”.
I don’t know what’s the matter and is there any solution?

Thanks a lot.

Can you restart the app?

yes, I’ve tried, but do not work.

Do you have something in Preferences > Addons > Alternate Plugins Repo? And can you try if you can reach this URL: “https://raw.githubusercontent.com/schriftgestalt/glyphs-packages/glyphs3/packages.plist” It might be that the firewall is interfering.

And does the Plugin Manager show anything when you open it? Maybe you can install from there?

yes, I use a network proxy now, but it has a new problem as show below.

Then remove the Glyphs Python from the Repositories folder and try again. The installation takes some time, so you need to wait that the button switches to “Remove”. Then restart Glyphs.

It’s done. I know it’s the problem of my network, thanks.:slight_smile:
And how to install the module ‘xlrd’ into the python 3.9.1 of G3.
and my script ‘import xlrd as xd’ feedback the wrong msg: No module named ‘xlrd’
this code is ok in G2.

Thanks a lot.

Glyph 2 was using the system python and thous could pick up installed modules. The Glyphs Python is independent of this.
You need to install in a place there the glyphs python can find it. Check “sys.path”:

import sys
print("\n".join(sys.path))

If you installed it by pip in the system python, you can add that path to sys.path in Glyphs.

Add that to the top of your script.

system_site_packages_path = "path to site-packages"
if system_site_packages_path not in sys.path:
    sys.path.append(system_site_packages_path)

OR:

manually install python3 on your system (by downloading it from python.org (you need to use version 3.10, not 3.10.1 as the later is not supported in Glyphs, yet. I just fixed that)). Then restart Glyphs and select the new python installation in the Preferences.

Then all system installed modules will work in Glyphs, too.

After I uninstall python3.10.1 and install python3.10.0, which shows No module ‘objc’.
and I can see it worked in system cmd as below show:
why?
Thanks.

I tried to Glyph python3.90’s directory and pip install ,but it also installed into 3.10.
I don’t know the reason.
Could you help ?

I copied the module xlrd’s all path and files from 3.10’s ‘sit-packages directory’ to 3.9’s same ‘sit-packages directory’, it works. :slight_smile:

Based on that screenshot, you ran the pip3 command from the Python 3.10 installation. It was likely in your $PATH before . (the current directory). If you want to run pip3 from the directory you’re in, then do:

:; ./pip3 install xlrd

The :; is simply the shell prompt. The ./pip3 is specifying the relative path starting with the current directory instead of looking through the $PATH directories.

If the Python 3.9 install is in your $PATH then you could’ve also done:

:; pip3.9 install xlrd

fyi.

I just found a way to install modules with Glyphs python. Run this in Terminal:

cd ~
Library/Application\ Support/Glyphs\ 3/Repositories/GlyphsPythonPlugin/Python.framework/Versions/3.9/bin/pip3 install --target=Library/Application\ Support/Glyphs\ 3/Scripts **ModuleName**

That will install the module into the Scripts folder. I think I’ll add a specific folder to sys.path to keep it separated.