glyphOrder was changed when exporting

I am making font that including .notdef, .null CR and space.
To reorder glyphs, added custom parameter to

Font info… > Font > Custom parameter >
glyphOrder: .notdef, .null, CR, space, exclam, quotedbl, numbersign…such like this.

After exporting to OTF, the order has been changed to .notdef, space, .null, CR, space, exclam…
and exporting to TTF, the order was changed to .notdef, CR, space, null, space, exclam…

How can I fix this? or is this bug?

Which version are the you using?

The recommendation to add CR and null is in the process to be removed. And it was there only for TT based fonts. And the “.null” glyph is, according to other specs not a valid glyph name as only the “.notdef” is allowed to start with a period. I added the code that Glyphs will look for the “.null” glyph, too (but still only for TTF).

version 2.1.1 (789)

Yes, only for TT-flavored. Thank you, I see.

Regardless of the likely change to the OpenType specification, if we set the GlyphOrder parameter, we mean it to be used. I hope this can be fixed to work with OTFs as well at TTFs.