Glyphs 2.4.x hangs on macOS 10.12.1 when opening any .glyphs file while Glyphs 2.3.1-939 opens them fine

On my macOS 10.12.1, any build of Glyphs 2.4 (939, 941, 942) hangs when opening any .glyphs file that I try (I need to do Force Quit, otherwise it just hangs consuming 100% CPU). But Glyphs 2.3.1-922 opens the files fine. I cannot tell what’s the last version that opens them fine. I could try a few versions older than 2.4 but I don’t know how to download them. I tried a number of .glyphs files, to the same effect. This behavior is new — a few days ago it worked fine with 2.4.x. I have a number of plugins installed, including RMX.

I have disabled the plugins one by one and it turned out that it was ReporterToggler.glyphsPalette 1.1.0 ( ) that caused the hang.

1 Like

I believe this (also) should be reported here:

Thanks for letting me know. I just saw it now. Unfortunately I cannot reproduce it, because I don’t have Sierra installed. Adam reported the versions, so perhaps you GlyphsApp developers can tell me what changed in the meantime backstage?

Works fine for me. @twardoch, could you do a spindump (in Activity Monitor).