Glyphs 2 crashes at openning

I’m running Glyphs 2.6.6 on macOS Catalina 10.15.7
It suddently stopped working, it crashes when I try to open it. Last thing I did was installing the plugin Space Bar. I tried to restart Glyphs but I got this report.
I tried to download Glyphs 2 again but it does the same.
How could I try to fix that?

I can copy paste the whole report if needed.

Can you check what plugins you have installed? You can start the app by holding down the Option and Shift key to disable plugins.

Yes, I have these ones in the plugin folder. When the crash happenned for the first time I deleted the Space Bar plugin from the plugin and repositories folders.

Glyphs doesn’t crash when I start it with plugins disabled.
That’s strange because it worked fine before Space Bar and it’s not there anymore.

Update: I just removed “Show Smooth Node Angle and Proportion” and it works.

I also reinstalled Space Bar and this time no problem. I don’t understand, because I was using Glyphs with SSNAP for a few weeks without any issue, but at least it’s fixed!

We are trying to update the plugins to work with python 3.9 and I missed a detail that crashes Glyphs 2. I found the problem and will update the plugins again.

All right. Thanks for your help!