Glyphs 2 Licence not working

I have just sent an email regarding this problem, but I was just wondering if anyone else had had this issue. I have just upgraded to Glyphs 2. Firstly, I downloaded the software and tried to open it, assuming it would start the 30 day trial, with a view to then getting a licence. Instead I was immediately presented with a message pop-up which said:

Register Glyphs
The Test Period has expired.
Please visit to get a license.

I purchased a licence and downloaded it. When I dragged it over the App icon to activate it, nothing happened, as it does with the licence for Glyphs 1. Nothing I do will get it to highlight when it hovers over the App icon.

I am using Yosemite 10.10.3.

Any ideas?

Please download the app again. There was a problem on the server.

Perfect. It worked a treat. Thanks Georg. Annoyingly, I am not in my studio tomorrow, but am really looking forward to playing with my new toy as soon as I can – might just have to work on Saturday! Thanks again.