Glyphs 2 Wont open

I"ve tried a few things from the forum but nothing seems to work. I have tried uninstalling it too. It just won’t open at all on my mac fully up to date on software.

Do you see an error message?

Has it worked before?

Can you uninstall all plugins? (From ‘~/Library/Application Support/Glyphs/Plugin’)

No error message comes up, and apologies forgot to include that this happened after updating Glyphs. Ill try removing the plugins.

UPDATE: That didnt work.

What is actually happening? Is it crashing?

No, it literally won’t open at all, the icon on my mac hops as if it will open then nothing, worked fine yesterday until I updated it. I was trying to add a screen recording but it doesn’t seem video files are welcomed Ill make it into a little gif to show you.

Update: see what happens here:

Can you open it with option and shift keys held down? If yes, it is a problem with a plug-in.

If not, take a look at what happens in the while starting Glyphs.

holding Shift and option worked it looks like Add caps was the plugin problem

.! What’s the proper thing to do now?

OK, please:

  1. empty out your Plugins folder (best reached via Script > Open Scripts Folder),
  2. redownload the plug-ins you need through Window > Plugin Manager,
  3. make sure to reinstall the modules with Glyphs > Preferences > Addons > Modules.

Screenshot: not sure what you were trying to achieve. Please clarify.

The screenshot is what popped up when I opened Glyphs after trying shift Option method to open the program. Okay that worked but something is up with Add caps plugins it caused a crash is what it says when I open it. I removed the plugin until something’s updated.