Glyphs 3 app performance is slower than Glyphs 2

Can you try to activate the plugins one by one to see what is slowing down most? Maybe we can fix some of them.
e.g. I rewrote the Show Stem Thickness plugin and it should be much quicker now.

Thanks. I’ll check through them. At the moment, the RMX filters seems to be causing a slow down. I wonder if @TimAhrens is updating them?

How much RAM do you have? I have no problems with RMX but I have 64gb of RAM

Yeah, only 32 but I’m seeing similar on my new M1 too. Mainly it’s less responsive working within a few paragraphs of text.

32 should be plenty.

1 Like

I would suggest keeping a few words or a few lines of text in Edit View. If you want to preview multiple paragraphs of text (or even the contents of an entire book) you can use Text Preview from WindowText Preview. It updates live and Edit View stays snappy no matter how much text you are previewing.


Thanks @FlorianPircher I’ll do that.

What exactly is getting slow? Is it while you are using RMX? Is it on export? Is it the start-up?

During ordinary use, having RMX installed has no impact as it is completely inactive, there is no RMX code running at all.

If might be that the RMX is used as a Filter in an instance and the Preview is updating the instance all the time.
@Ginjam can you send me the file that I can have a look?

Thanks @TimAhrens and @GeorgSeifert
Glyphs is pretty fast when I disable plugins. I then removed them all except RMX and there’s a slight lag generally when scrolling around text and nudging points etc. But hey, It’s nothing major just noticeable compared to Glyphs2.
There’s no lag while actually using the RMX tools, and it’s not a filter issue as I’m swapping between projects, one of which is new and with a small character set.
For now I’m going to use more text preview and see how it goes.

Performance issues for Glyphs 3 still a thing in June 2021. I find myself going back to Glyphs 2 for larger projects, sadly. My laptop is fairly old (mid 2015) so that obviously also plays a part.

Can you try without any plugins by starting the app with the Option + Shift key pressed?
That should give good performance on your machine (I use machines from that time, too).

Then start again normally and try to deactivate plugins one by one to see if one of it causes a particular slowdown.