Glyphs 3 crashing on launch via Vanilla error

Hi There!

I’m receiving this error upon launch. The plugin that is triggering the error is one that I wrote, which uses Vanilla.

  File "", line 20, in <module>
    from vanilla import *

  File "", line 1, in <module>
    from vanilla.vanillaBase import VanillaBaseObject, VanillaBaseControl, VanillaError

  File "", line 2, in <module>
    from packaging.version import Version

ModuleNotFoundError: No module named 'packaging'

I’m running Monterey (12.4), with Glyphs build 3.1 (3133).

Any idea what is causing this? This plugin previously ran perfectly, and the same error is being called for each of my plugins that use Vanilla.


1 Like

I’m having the same issue.

1 Like

I have the same issue and some plugins and scripts don’t work

Screenshot 2022-09-08 at 02.07.03

and I have the vanilla module already installed

1 Like

Same here. Mekkablue’s scripts don’t work.

I have received other reports as well. We’re investigating.

  1. Which Python do you have selected in Glyphs > Preferences?
  2. Does it work after uninstalling and reinstalling all modules in Window > Plugin Manager > Modules, and restarting Glyphs?
  3. Except for the ones you wrote yourself, how did you install the affected scripts and plug-ins? Does uninstalling and reinstalling via Plugin Manager work?
  4. Which exact macOS version are you using? I cannot reproduce on machines with 12.5.1.
  1. 3.9.1 Glyphs
  2. Tried uninstalling and reinstalling all modules, no change
  3. Everything is from the Plugin Manager, uninstalling and reinstalling no change
  4. I’m on 12.5.1, M1


This began for me after a restart, so I wonder if it had something to do with a cutting edge release of Glyphs?

I have Python 3.9.1 (Glyphs) selected.

I’m on Monterey 12.4.

Reinstalling all modules does not fix the problem.

I am only seeing the error re: plugins I wrote myself, installed via aliases in my plugins folder.

I have the exact problems on both of my machine (Intel & m1)

  1. Glyphs 3.9.1 (G3 build 3134, Intel) & Glyphs 3.9.1 (G3 build 3135, M1)
  2. Uninstaling and reinstalling vanilla modules via plugin manager on both machines, still got the error messages
  3. Currently only several plugins that requires vanilla doesnt work, I havent check the scripts yet
  4. MacOs 10.15.17 (Intel) & MacOs 12.5.1 (M1)

Yes, specifically the error messages I am seeing concern plugins that use Vanilla.

List of plugins that didnt work

Intel Python 3.9.1 (Glyphs), Glyphs 3 3.1.1 (3134)

Frederik “fixed” a waring that introduced a dependency that is not installed by default.
fix deprecated warning (#169) · robotools/vanilla@9b96eef · GitHub

I changed the repo for the vanilla module that doesn’t contain the breaking commit. Please remove and re-install “vanilla” from the plugin manager.

1 Like

Thanks @GeorgSeifert, it is working properly right now, :smiley:

1 Like

Re-installing the Vanilla module fixed the issue for me. Thank you!