Glyphs 3 is forcing fi / fl ligatures to double-width

I’m doing some work on Cascadia Code (monospace design) and am finding that Glyphs 3 is forcing the fi and fl ligatures to be double-width (2400) rather than how they were designed (1200).

Even if I try to change this value, it changes it back. (277.5 KB)

Can you send me the file?

Will do

I noticed this isssue too, but thought it might be me., glad it’s not just me ¯\_(ツ)_/¯

I can confirm the same problem.

I see. I’ll fix it. for now, you can force the spacing of all (most) glyphs to the right width by adding a “.monospace” number value in the masters.

Thanks Georg. It would also be helpful if the ifFixedPitch parameter didn’t force all glyphs in the font to be fixed pitch :slight_smile:. There are valid reasons one might want to create non-exporting glyphs (such as half-width forms that will be used as components) that would be easier to work with if they weren’t forced to be full width.

I see. But that use case is an exception. You can overwrite this by adding a =XX width key in those glyphs.

:+1: Thanks!

Hi, I’ve got a similiar problem. I’m producing a font having proportional and monospaced in one file. And the monospaced has also double width ligatures. I need to produce it as google font and they require the isFixedPitch to be set. How can I set the bit only for instances? Thx.

I added isFixedPitch to the instance settings

1 Like

Thx Georg!