Glyphs 3 Not opening

Have updated to Glyphs 3 from the previous version, it was working for a while and now it won’t open. This annoying as I started to work on projects with the new version of glyphs and now I can’t work on them.

Hope someone can help me out :)))

1 Like

What version if MacOS do you have? And did you install some plugins in the meantime?

I have macOS Catlina 10.15.5, I haven’t put any new plugins on the new version of glyphs, but these were the ones I had on the older version Screenshot 2020-11-20 at 17.24.11

Many from the old version had issues. Please remove them then reinstall clean using the Plugin Manager.

My guess would be heatmap needing an update. @SimonC would know for sure.

Yeah, I haven’t updated Heatmap, and that’s ObjC so will need a rewrite. I’ll work on it.

1 Like

I don’t think it needs a rewrite (unless you plan bigger changes). The API has changed but that can be amended quite easily.

Hi - I’m getting this exact same issue and running High Sierra 10.13.6.

I already tried reinstalling and that didn’t fix it. I had installed some plugins previously via the plugin manager, but now I can’t find the folder where they reside.

/Users/[username}/Library/Application Support/Glyphs 3/Plugins

The Plugins folder contains an alias to the plugin which should be in the Repositories folder.

1 Like

Thanks! Worked.

Just posting for posterity: For anyone who has trouble seeing the hidden ‘Library’ folder, Hold down Cmd + Shift + . (period) to show. :slight_smile:

Or open the Go menu in Finder and press the Option key. That unhides the Library in the menu.