Glyphs 3 / Python 3 / M1

I have had the chance to check the python environment with a completely fresh install Big Sur on M1 (no migration). Unfortunately it doesn’t work:

After the first start of Glyphs 3, so far everything is clean. As soon as I install a plugin that needs python 3, I get this message:

**An installed plug-in requires Python 3. Do you want to download and install it now?**

You can also install it later in the Plugin Manager.

Of course I tried that. Went to the `Plugin Manager > Modules and installed Python there. Several times. Doesn’t do anything. After a Glyphs restart, the message from above still comes up. Also when I try to run anything from the Macro Panel.

Additionally, the Popup Menu in Preferences > Addons > Python Version is empty and I can’t choose any python there, even though I got the legacy python 2.7 as well as a working python 3.8 (in /usr/bin/python3)

Since I got those 2 pythons already, I was hoping to not need to install any more pythons, to keep this machine a bit cleaner :man_technologist:
Is it even necessary to install that Plugin-Manager-Python if you got the other ones already?

Glyphs 3.0.1 (3039), Mac OS 11.1

The Glyphs python module only works on Intel macs.

For M1 machines, this worked for me:

Install python from They supply an universal2 installer package (currently this is the direct link:

Then run this in the Terminal:

which python3.9

and confirm that it mentioned “arm”.

You need to install pyobjc:

pip3.9 install pyobjc

Restart Glyphs and select the python version in Preferences > Addons and restart Glyphs again.

1 Like

Thank you! Will try later and let you know.

Do you think, one can uninstall the python 3.8 (currently existing) then? Otherwise there are 3 pythons around. (Will not remove the 2.7 legacy one, for legacy reasons).

Multiple pythons are not a problem. I have 5 different versions installed. The 2.7
version is from the system, don’t mess with it.
There should be a python3 from the system, but it might need to be installed on first usage, just as git worked on previous systems.

I’m getting an M1, soon. Will try to document that with a fresh system.

1 Like

Same here, fresh system, want to keep it as fresh as possible :slightly_smiling_face: That’s why I asked. Thank you a lot. Will hang the feedback in here later …

On thing I might need to add is the path of the system python version that Glyphs can find it.

1 Like

Thank you! which python 3.9 -> /Library/Frameworks/Python.framework/Versions/3.9/bin/python3.9

It doesn’t mention “arm”, but the python warnings are gone and python 3.9 is preselected in the preferences, as well as Speedpunk showed its starting screen (hence it seems to work).

However Glyphs3 hangs up every time I want to open a file now, as well as in the Preferences Pane when I click through the tabs. For example the Sample Strings tab (happened several times, but not anymore now). In both cases, the beachball comes up, it’s animation is even choppy and I have to force kill Glyphs.

Got a bunch of logs in the console like this Coalition Cache Hit: app<> [4057]

The hanging is most likely related to a python string used as a key in user defaults. The Glyphs.defaults should check that but it is a problem if someone uses NSUserDefaults directly, and doesn’t use NSString.

Is there a way to reset the user defaults completely? I cannot start Glyphs anymore without it hanging. And it’s more or less a very fresh system (just had installed 3 plugins before).

I found the defaults file and deleted it, to make Glyphs create a new one. But no help there. Do you want to have a look at the plist? The entries look alright to me, stored as Strings, Arrays, Dictionaries, Data, Bools and Numbers only. 30 items.

There is a plugin that messes it up on startup. The problem doesn’t persists a restart.

Thank you! The latest cutting edge fixed it. :innocent:

Hey! I’m at the same point as @Mark on Dec '20, only that I’ve already installed the latest cutting edge version, that seemed to do the trick for Mark. I have no knowledge about Python and only followed your instructions @GeorgSeifert on how to install Python 3.9.
Glyphs hangs itself up when I try to open a file without having a new project already open. Help?

What plugins do you have installed?

JFYI Back then when my Glyphs (non-cutting-edge at that time) hung up, I had SpeedPunk and Angled Handles installed.

RMX and Red Arrow, Show Angled Handles, Show Smooth Node Angle and Proportion and Show Stem Thickness from the Glyphs plugin manager.

And what version of Glyphs do you have?

3.0.2 (3048)

Can you try the latest cutting edge version?

Done. Everything works just fine now – thanks Georg!

1 Like

I’ve got an M1 MBP and I have an issue seemingly related to this. I come across plugin errors every time I start the app, saying the bundle wasn’t loaded because the version for the current architecture was not found, and telling me to install an universal version. What’s causing the error?
I have installed Python 3.9 following Georg’s comment (no mention of ‘arm’ in mine either) as well as pyobjc, not to mention cutting edge versions.