Glyphs 3: Variable font exporting without errors but blank characters

I upgraded from G2 to G3 and noticed that none of my font files can export variable fonts, where they did work previously. I tried exporting TTF, WOFF, WOFF2 they are all blank on export. No error messages can be seen. Though it does crash quite regularly.

G: 3.0.3 (3085)
M1 macOS.




File:
logodebug.glyphs (45.0 KB)

I just uploaded a new version that fixes this.

1 Like

Hi GeorgSeifert, thanks for the fast reply and the even faster fix! It works fine to export the font, thought I’m getting some issues with components flying around on interpolation in the exported TTF:

I uploaded the Glyphs file with j and t intact where the issue is happening.

Any reason you are using a nested component for the tail in the j? You could just use the terminal glyphs directly (and add the _connect) anchor to it. What happens is that when exporting, it is decomposing the _part.terminal and this removes the _connect anchor. For some reason, the automatic alignment is only run on the Bold master (that is moving the terminal without the anchor next to the stem).

Yes that fixed it. Removed the nested setup and it interpolates correctly now. I wrongly assumed components needed to be prefixed with _part which wasn’t the case.

Sidenote: I felt compelled to mention how impressed I am with the speed & accuracy of the support in here. It is in my opinion unmatched to any other SaaS products. Not mentioning that its mostly managed by the two founders and not a dedicated support team. Good stuff