Glyphs App trying to access my calendar?

Glyphs App has been very unstable for me since I updated some long unupdated script repostiries and modules, I just got a crash from trying to run a script and then when it re-opened with the Terminal running I got this:

2024-03-18 11:23:44.108 Glyphs 3[9027:304575] CoreData: XPC: Unable to load metadata: Error Domain=NSCocoaErrorDomain Code=134070 "An error occurred in the persistent store." UserInfo={Problem=request failed, insufficient permission}
CoreData: error: addPersistentStoreWithType:configuration:URL:options:error: returned error NSCocoaErrorDomain (134070)
CoreData: annotation: userInfo:
CoreData: annotation: 	Problem : request failed, insufficient permission
CoreData: annotation: storeType: NSXPCStore
CoreData: annotation: configuration: (null)
CoreData: annotation: URL: file:///Users/weihuang/Library/Calendars/Calendar%20Cache
CoreData: annotation: options:
CoreData: annotation: 	NSMigratePersistentStoresAutomaticallyOption : 1
CoreData: annotation: 	agentOrDaemon : 1
CoreData: annotation: 	NSInferMappingModelAutomaticallyOption : 1
CoreData: annotation: 	serviceName :
CoreData: annotation: 	NSPersistentHistoryTrackingKey : {
    NSPersistentHistoryTrackingEntitiesToExclude =     (

macOS 11.7.10 (20G1427), 3.2 (3246)

This was the script I tried to run:

I’ve sent the crash report.

When I reverted to this commit

The crash no longer happens…

Can you reproduce the crash reliably? Pretty sure it’s not the script per se that caused it.

The error message in the first post is strange. Glyphs doesn’t do anything I know of with CoreData. So I don’t know what going on.
I have something in the works for give more control over the sorting.

Yes I can reliably reproduce the crash. GA hangs and then crashes, though only one time did it eventually execute the script.

Edit 1:
OK this was once a problem for me a long time in the past, but I figured out what causes it to crash:

If I run the script by navigating to it in the menu with my mouse, it does NOT crash, If i use my keyboard shortcut which is set to Ctrl+Opt+Shift+C, it will reliably crash???

I see your crash reports. But I have no clue what’s happening. can your try a different shortcut? Maybe it triggers something else that causes the crash?

I tried a different shortcut still got the same issue. I tried even without any other plugins installed too.

I checked my system logs and saw these errors:

Mar 19 09:53:42 homecomputer[1]: Coalition Cache Hit: app<> [6042]
Mar 19 09:53:54 homecomputer Glyphs 3[8505]: getattrlist failed for /System/Library/Extensions/AppleIntelKBLGraphicsGLDriver.bundle/Contents/MacOS/AppleIntelKBLGraphicsGLDriver: #2: No such file or directory
Mar 19 09:53:54 homecomputer Glyphs 3[8505]: getattrlist failed for /System/Library/Frameworks/OpenGL.framework/Resources//GLRendererFloat.bundle/GLRendererFloat: #2: No such file or directory
Mar 19 09:53:55 homecomputer Glyphs 3[8505]: DEPRECATED USE in libdispatch client: Setting timer interval to 0 requests a 1ns timer, did you mean FOREVER (a one-shot timer)?; set a breakpoint on _dispatch_bug_deprecated to debug

It looks like this is a Big Sur issue:

Seems like I’ll need to update my macOS…

What’s strange is that if I copy the script into the old mekkablue folder it doesn’t produce this crash. I wonder if it’s something in the init scripts?