Glyphs Import Script

I have Use Custom Naming turned on in my .glyphs file but when I import the .glyphs file into FontLab some glyphs still get renamed?

Also for some glyphs, when I do a roundtrip the starting points changed. I’ll send the files to you.

Hi @oneweioranother, I don’t know very well the specifications, but you cannot have hyphen in glyph names if you want to use your project outside Glyphs, Please see what @GeorgSeifert commented about hyphen:


And see what the OpenType Specifications says about glyph names:

###2.f.i. Glyph name

A glyph name may be up to 31 characters in length, must be entirely comprised of characters from the following set:

A-Z a-z 0-9 .(period)_ (underscore)

[…]
###2.g.i. Ranges

A range of glyphs is denoted by a hyphen:
[<firstGlyph> - <lastGlyph>]
Spaces around the hyphen are not required since hyphens are not permitted in feature file glyph names. For example:
[\0-\31]
[A-Z]

For compatibility reasons (I think) you cannot export (outside Glyphs) a glyph with a name containing illegal characters like, pa-deva, or alef-ar or exceeding the 31 character length:
u069c.seenWith3DotsBelowAnd3DotsAbove
Some situations are going to export glyphs using its production name or eliminating the hyphen. I can be wrong about this but that is what I have discerned from comparing the original and the resulting glyph names using the FontLab’s macro “Glyphs Import”.
Best,

Nicolás

1 Like

Thanks @Nicolas for the info, none of my glyph names had hyphens though. It was for names like the *commaccent ones, seems to be a recent issue, I just reverted to a previous version of the script.

The import script does in deed convert to font to production names, the same as what would happen if you export the font. This is independent from the “Use custom names”. You need to add a Don’t use Production Names parameter to prevent this on export. I have to add support for this parameter in the import script.

Do I add this parameter in the Master info?

No in the instances.