Glyphs Mini crashes on import

After its trial expired, and I converted it to a paid app, my Glyphs Mini 2 app stopped working.

If I try to open any OpenType font with Glyphs Mini, it crashes instantaneously. This is true of every font I try to open—fonts included with Mac OS, the twenty-odd fonts I’ve purchased, Google fonts, Microsoft fonts, you name it.

I think I may once, weeks ago, have occasionally been able to open fonts with Glyphs Mini. But then, I remember, it would crash instantaneously when I tried to “Save” or “Export” them.

I could see no way around the problem of Glyphs Mini crashing whenever I tried to open a font. So I downloaded the full Glyphs app and used that in trial mode, until its trial expired, too. The trial version of the full Glyphs app would successfully open and export OpenType fonts. (It, too, would crash every time on "Save,” which I assumed—perhaps too optimistically—was a limitation of the trial version.)

Why does this constant, immediate crashing on import happen, and what can I do about it? I would love to use my copy of Glyphs Mini. Despite paying for it, though, I cannot use it to edit fonts at all.

I am currently running Mac OS 10.15.7 on a MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports) with 16 GB of RAM.

I emailed this question—which I suppose is equal parts question, complaint, and request for a refund if the app can’t be made to work—to Glyphs. I was asked to post it here so that it could be answered better.

Thank you so much for your help.

What version of Glyphs Mini do you have (App Store, or from our website)?

Two things:

  1. can you try in a different user, and
  2. can you make sure you have updated to the latest version of Glyphs Mini

I am running Glyphs Mini 2.1.4. Glyphs Mini’s update function says I am up to date.

I didn’t check your license :wink: just to understand what binary you have.