Glyphs Mini (Version 1.5.7 (49)) still doesn't export and crashes

I updated to the latest version of Glyphs mini: Version 1.5.7 (49) it still crashes often and exporting doesn’t work properly.

I keep getting the error:
"(fontname).otf" couldn’t be copied because you don’t have permission to access “Desktop”.
To view or change permissions, select the item in the Finder and choose File > Get info.

I am quite sure that the permissions in my system are exactly what they should be.

Please please please fix Glyphs mini! It’s a useless app if you can’t export your work!

I have had this app for such a long time and it never worked properly. So frustrating.

(also I can’t find the thread we started about this problem anymore… did you delete it??)

What happens if you uncheck the export destination button and choose the Desktop manually?

If you select your username on your own post, it should show your Forums profile; there'll be a list of your posts on that page:
I've only tried it a few times now but it looks like this bug only happens when you have the export destination box checked. I know, and the previous thread (from last week) doesn't show there anymore, or in any searches I do.