Glyphs not starting at all

Hello all,

I’m having a serious issue.

I made a time-machine backup of my entire Mac, while also working on a glyphs file. Everything seemed fine. When the backup was finished I saved the glyphs file and updated the backup. Then I closed Glyphs, realized I forgot something, and tried to open it again.

Now, Glyphs won’t open AT ALL. It keeps bouncing for ages, and after that does not open. It’s tagged as non-responsive and I can’t open any file.

I already tried downloading the Glyphs trial version from the website, but the same problem occurs. At some point I got an error about RMX tools, so I deleted it, but nothing changed. I also tried opening Glyphs while holding shift-option. Lastly, I updated my Mac to Catalina (10.15.3), but the problem still persists.

In case it matters: my glyphs files are saved in a dropbox folder.

Please help,


MacBook Pro (13-inch, Mid 2012)

Redownload the app, and open it in a different user. And update again to the latest beta. Then switch back to the original user.

Watch the messages for anything suspicious (search for “glyphs”). If it works in the other user but not in your default user, consider removing pref files as set forth in the Crashes tutorial.

I don’t think it has to do with the backup though. Do you have any system optimizing/maintenance tool like MacCleaner? If yes: Please stop using it and make sure to properly and completely uninstall it.

Try removing all plugins (hold down Option+Shift). Delete the preferences.

After I deleted the pref files and RMX tools it opened, although taking a very long time. I then disabled all plugins and updated to the latest cutting edge version. It seems to be working now, but it’s still super slow (taking minutes on an otherwise decent laptop) when starting up.

And no, luckily I don’t use MacCleaner or the like :slight_smile:

Same in a different user?

Can you keep an eye on what happens in Activity Monitor (in /Applications/Utilities)? To see what exactly is causing the slowdown.

I haven’t tried a different user yet, but will do so later. Should I still be looking at the messages (and where do I find those?) or just activity monitor?

All of it please :slight_smile:

Sorry for my slow reply. I had some deadlines to attend to. The problem disappeared as suddenly as it appeared, so I still have no clue what caused it.

What’s more, I’ve gotten similar issues with other applications, that are now also acting normal again, so it seems not Glyphs-specific. If it occurs again, I’ll follow your instructions above!

1 Like