Glyphs not working after export

So after posting this yesterday -
I corrected my unicode and got the new glyphs I had added to work. However, I am adding to a pre-existing font and after the export some glyphs that had worked previously are no longer working, and other have shifted a few pixels in various directions. Can anybody help me solve this? It is really slowing down my web development.

Opening an existing font, and then recompiling it = different font. Better import the original work files, rather than compiled fonts. But read this:

What was the format of the original file, TTF or PS-flavored OTF? Did you check Keep Glyph Names and Disable Automatic Alignment in the app preferences?

Most shifts are probably a result of different vertical metrics.

And did you check the unicodes of the existing glyphs?


“Glyph Names and Disable Automatic Alignment” are not in the preferences for Glyphs Mini.

I am specifically working on adding glyphs to the Entypo font.

So the unicode is in great shape coming in. What can I do better here?

Can you post some screenshots of the moving glyphs, before and after Glyphs?

Georg Seifert

I would love to, but I don’t see a good way to do that here.

Use CloudApp and link your pics here.

Here you go:

  1. Where is the screenshot from?
  2. How did you install the font in order to test it? Are you aware of font cache problems?
  3. In Font Info, what are your Ascender/Descender settings?
I opened the Entypo Social OTF in Glyphs mini. The Google+ logos lost their Unicode, probably due to a bad glyph name, which contain a plus symbol. You would have to reset the Unicode by naming them uniF310 and uniF30F and then renaming them back to google and c-google.


Thanks for taking a look, but I am having trouble with the standard entypo font, not the social version.

The screenshots are from a website I’m working on, so it is the glyphs being loaded via a CSS call to their Unicode. It is important to note that I have been using the original entypo font without any issues. It is only my edited version that is causing these problems.

I am aware of font cache problems and have tried learning my font cache.

Ascender 750
Descender -250

I cannot seem to reproduce the problem. Can you send your .glyphs file, and the HTML/CSS you are using to support at this domain, please?

The screenshots are taken from Safari in OS X, I assume?


Thank you for all your help. Sorry for the delayed response on this.

There are 6 glyphs meant to show in that example. Only four do.
The first two don’t show up. The last two are new glyphs added to the original font.

I’ll post an example of the line-height/baseline shift shortly.


And here is a link to download my Glyphs file:

It doesn’t surprise me that the icons are shifted. The different files use a different UPM and the plus version has an additional LineGap set. How did you convert to webfonts?

The missing characters have in common that they are not in the Basic Multilingual Plane. Not really sure why they don’t work. They definitely are in the TTF.

The automatic calculation of the different vertical metrics values is a bit different but more consistent in the new file. Glyphs Mini has no option to customize that. So you would need to change your CSS.

The fonts exported from Glyphs Mini are fine. How did you generate the webfonts? They miss the CMAP table that references the upper plane unicode (all five digits unicodes).

I used FontPrep to convert to webfonts. Where can I find/set the UPM and line gap settings?

In Glyphs?

I assume FontPrep overrides these settings somehow. Perhaps try another service.